]> code.ossystems Code Review - openembedded-core.git/commitdiff
base-passwd: sed installed file instead of original
authorSaul Wold <sgw@linux.intel.com>
Wed, 26 Feb 2014 13:49:29 +0000 (15:49 +0200)
committerSaul Wold <sgw@linux.intel.com>
Fri, 28 Feb 2014 09:32:11 +0000 (11:32 +0200)
When we change the ROOT_HOME the sed regex does not match if we are running
the do_install() a second time, so sed the installed file and preserve the original
so that the sed regex is matched correctly in the original

[YOCTO #5765]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/base-passwd/base-passwd_3.5.29.bb

index 0205f2e217524d31baf9073ae919f4551064fafa..59bd413b49f242adb84ab7d6c61ae1a1a9f6580b 100644 (file)
@@ -28,8 +28,8 @@ do_install () {
                ${D}${mandir}/pl/man8/update-passwd.8
        gzip -9 ${D}${mandir}/man8/* ${D}${mandir}/pl/man8/*
        install -d -m 755 ${D}${datadir}/base-passwd
-       sed -i 's#:/root:#:${ROOT_HOME}:#' ${S}/passwd.master
        install -o root -g root -p -m 644 ${S}/passwd.master ${D}${datadir}/base-passwd/
+       sed -i 's#:/root:#:${ROOT_HOME}:#' ${D}${datadir}/base-passwd/passwd.master
        install -o root -g root -p -m 644 ${S}/group.master ${D}${datadir}/base-passwd/
 
        install -d -m 755 ${D}${docdir}/${BPN}