]> code.ossystems Code Review - openembedded-core.git/commitdiff
wic: remove systemd-boot for x32
authorSaul Wold <sgw@linux.intel.com>
Tue, 26 Sep 2017 00:52:17 +0000 (17:52 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 26 Sep 2017 09:14:17 +0000 (10:14 +0100)
Currently systemd-boot actually incorporates libgcc, since the
systemd-boot needs to be built with 64bit instructions it can not
use the x32 based libgcc.

Use the new override to ensure it gets overriden, linux-gnux32 could
not be used because x86-64 has higher priority.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/image_types_wic.bbclass
meta/recipes-core/meta/wic-tools.bb

index e60dca7237ac2733d83f81182c3c3a01d510dcf9..222ae004338d7678f3c9073030fc06f8b7f46c56 100644 (file)
@@ -45,6 +45,7 @@ WKS_FILE_DEPENDS_DEFAULT = "syslinux-native bmap-tools-native cdrtools-native bt
 WKS_FILE_DEPENDS_BOOTLOADERS = ""
 WKS_FILE_DEPENDS_BOOTLOADERS_x86 = "syslinux grub-efi systemd-boot"
 WKS_FILE_DEPENDS_BOOTLOADERS_x86-64 = "syslinux grub-efi systemd-boot"
+WKS_FILE_DEPENDS_BOOTLOADERS_x86-x32 = "syslinux grub-efi"
 
 WKS_FILE_DEPENDS ??= "${WKS_FILE_DEPENDS_DEFAULT} ${WKS_FILE_DEPENDS_BOOTLOADERS}"
 
index 57dd37a44055db51423351d3cb29138ac801cb5c..09eb409e8742d9ea83917f0e5e6ec9dfe4473624 100644 (file)
@@ -10,6 +10,7 @@ DEPENDS = "\
            "
 DEPENDS_append_x86 = " syslinux grub-efi systemd-boot"
 DEPENDS_append_x86-64 = " syslinux grub-efi systemd-boot"
+DEPENDS_append_x86-x32 = " syslinux grub-efi"
 
 INHIBIT_DEFAULT_DEPS = "1"