]> code.ossystems Code Review - openembedded-core.git/commitdiff
buildtools-tarball: add nativesdk-mtools for `wic ls'
authorhongxu <hongxu.jia@windriver.com>
Wed, 8 Apr 2020 10:30:15 +0000 (18:30 +0800)
committerSteve Sakoman <steve@sakoman.com>
Thu, 30 Apr 2020 21:59:59 +0000 (11:59 -1000)
On ubuntu 18.04.1, it does not provides `mdir' by default
which caused `wic ls **.wic' failed on fat partition

...
$ wic ls build/tmp-glibc/deploy/images/xilinx-zynqmp/wrlinux-image-std-xilinx-zynqmp.wic

ERROR: Can't find executable 'mdir'
...

Add nativesdk-mtools to buildtools-tarball and use buildtools
to provide mdir

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-core/meta/buildtools-tarball.bb

index aa55cde84a96c2a7e7dbd15d221c98b6fc9cf499..977b6a5e1dcbdb3491b3f6746a275dec8c04e712 100644 (file)
@@ -26,6 +26,7 @@ TOOLCHAIN_HOST_TASK ?= "\
     nativesdk-libnss-nis \
     nativesdk-rpcsvc-proto \
     nativesdk-patch \
+    nativesdk-mtools \
     "
 
 MULTIMACH_TARGET_SYS = "${SDK_ARCH}-nativesdk${SDK_VENDOR}-${SDK_OS}"