]> code.ossystems Code Review - openembedded-core.git/commitdiff
update-alternatives-cworth: switched to opkg
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 19 Mar 2008 14:27:52 +0000 (14:27 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 19 Mar 2008 14:27:52 +0000 (14:27 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4051 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/update-alternatives/update-alternatives-cworth-native_0.99.154.bb
meta/packages/update-alternatives/update-alternatives-cworth.inc
meta/packages/update-alternatives/update-alternatives-cworth_0.99.154.bb

index 5c7b7289abc936faa9f3605c2a3818affb8b0ed4..b20dab18f15e1f87050a480fd95157a6841d2118 100644 (file)
@@ -2,11 +2,11 @@ require update-alternatives-cworth.inc
 inherit native
 
 PROVIDES += "virtual/update-alternatives-native"
-RPROVIDES += "update-alternatives-native"
+RPROVIDES_${PN} += "update-alternatives-native"
 
 do_stage () {
     install -d ${sbindir} \
-               ${libdir}/ipkg/alternatives
+               ${libdir}/opkg/alternatives
 
     install -m 0755 update-alternatives ${sbindir}/update-alternatives
 }
index 5a1cf3e7edf9ef95abb8d1adbca603eef5e5940f..78d890e6de1905731ace3df2918c44029ddec4b3 100644 (file)
@@ -1,6 +1,6 @@
 LICENSE = "GPL"
 SECTION = "base"
-SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')}"
-S = "${WORKDIR}/ipkg/C"
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target/;module=opkg;proto=http"
+S = "${WORKDIR}/opkg"
 PACKAGE_ARCH = "all"
 PR = "r1"
index cf3c8fbc2ba4ae3ad975257981f4a63a99b73d59..82700f0f95d0c6726cda869d72767c2a46d8833d 100644 (file)
@@ -6,7 +6,7 @@ RPROVIDES_${PN} += "update-alternatives"
 do_install () {
     install -d ${D}${sbindir} \
                ${D}${sysconfdir}/alternatives \
-               ${D}${libdir}/ipkg/alternatives
+               ${D}${libdir}/opkg/alternatives
 
     install -m 0755 update-alternatives ${D}${sbindir}/update-alternatives
 }