]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-xf86-config: add qemux86-64 xorg.conf
authorKevin Tian <kevin.tian@intel.com>
Fri, 6 Aug 2010 01:45:49 +0000 (09:45 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 6 Aug 2010 17:33:51 +0000 (18:33 +0100)
copy from qemux86 to make xserver works on qemu x86-64 platform. However
full GUI doesn't pop up yet due to other keycode/theme problems in matchbox.

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/packages/xorg-xserver/xserver-xf86-config/qemux86-64/xorg.conf [new file with mode: 0644]
meta/packages/xorg-xserver/xserver-xf86-config_0.1.bb

diff --git a/meta/packages/xorg-xserver/xserver-xf86-config/qemux86-64/xorg.conf b/meta/packages/xorg-xserver/xserver-xf86-config/qemux86-64/xorg.conf
new file mode 100644 (file)
index 0000000..4216de7
--- /dev/null
@@ -0,0 +1,68 @@
+
+Section "Files"
+EndSection
+
+Section "InputDevice"
+    Identifier    "Generic Keyboard"
+    Driver        "kbd"
+    Option        "CoreKeyboard"
+    Option        "XkbRules"    "xorg"
+    Option        "XkbModel"    "pc105"
+    Option        "XkbLayout"    "us"
+EndSection
+
+Section "InputDevice"
+    Identifier    "Configured Mouse"
+    Driver        "vmmouse"
+    Option        "CorePointer"
+    Option        "Device"        "/dev/input/mice"
+    Option        "Protocol"        "ImPS/2"
+    Option        "ZAxisMapping"        "4 5"
+    Option        "Emulate3Buttons"    "true"
+EndSection
+
+Section "InputDevice"
+    Identifier    "Qemu Tablet"
+    Driver        "evdev"
+    Option        "CorePointer"
+    Option        "Device"        "/dev/input/touchscreen0"
+    Option        "USB"           "on"
+EndSection
+
+Section "Device"
+    Identifier    "Graphics Controller"
+    Driver        "vmware"
+EndSection
+
+Section "Monitor"
+    Identifier    "Generic Monitor"
+    Option        "DPMS"
+    # 1024x600 59.85 Hz (CVT) hsync: 37.35 kHz; pclk: 49.00 MHz
+    Modeline "1024x600_60.00"   49.00  1024 1072 1168 1312  600 603 613 624 -hsync +vsync
+    # 640x480 @ 60Hz (Industry standard) hsync: 31.5kHz
+    ModeLine "640x480"    25.2  640  656  752  800    480  490  492  525 -hsync -vsync
+    # 640x480 @ 72Hz (VESA) hsync: 37.9kHz
+    ModeLine "640x480"    31.5  640  664  704  832    480  489  491  520 -hsync -vsync
+    # 640x480 @ 75Hz (VESA) hsync: 37.5kHz
+    ModeLine "640x480"    31.5  640  656  720  840    480  481  484  500 -hsync -vsync
+    # 640x480 @ 85Hz (VESA) hsync: 43.3kHz
+    ModeLine "640x480"    36.0  640  696  752  832    480  481  484  509 -hsync -vsync
+EndSection
+
+Section "Screen"
+    Identifier    "Default Screen"
+    Device        "Graphics Controller"
+    Monitor        "Generic Monitor"
+    SubSection "Display"
+        Modes     "640x480"
+    EndSubSection
+EndSection
+
+Section "ServerLayout"
+    Identifier    "Default Layout"
+    Screen        "Default Screen"
+    InputDevice    "Generic Keyboard"
+    # InputDevice    "Configured Mouse"
+    InputDevice    "QEMU Tablet"
+    Option         "AllowEmptyInput" "no"
+EndSection
index 058670d3679ded43f05dec89dc72a6cc1f759046..fc91285f27c6c0efcd9e3cb45b39bc05ef291f0a 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "X.Org X server configuration file"
 HOMEPAGE = "http://www.x.org"
 SECTION = "x11/base"
 LICENSE = "MIT-X"
-PR = "r8"
+PR = "r9"
 
 SRC_URI = "file://xorg.conf"