]> code.ossystems Code Review - openembedded-core.git/commitdiff
autotools.bbclass: use ordinary append for file-checksums update
authorMatt Madison <matt@madison.systems>
Sat, 25 Sep 2021 11:00:38 +0000 (04:00 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 26 Sep 2021 13:34:51 +0000 (14:34 +0100)
Commit 29daffc2410f06f36b779d5bf1fd1ef6e900ca8f added an
anonymous python function to append the site file dependencies
for do_configure. This causes any recipe that inherits allarch
after autotools to end up with a different set of file checksums
for each machine, since the anonymous python would get processed
before the TARGET_ARCH changes in allarch.

Use an ordinary += assignment to fix this.

Signed-off-by: Matt Madison <matt@madison.systems>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/autotools.bbclass

index bc0c2ea83e53ef184439109adaa55918ad6f1b4a..4ab24609904c080c486fdef2bc4b0967c2e5ebe4 100644 (file)
@@ -149,10 +149,7 @@ python autotools_aclocals () {
     d.setVar("CONFIG_SITE", " ".join(sitefiles))
 }
 
-python () {
-    sitefiles, searched = siteinfo_get_files(d, sysrootcache=False)
-    d.appendVarFlag("do_configure", "file-checksums", " " + " ".join(searched))
-}
+do_configure[file-checksums] += "${@' '.join(siteinfo_get_files(d, sysrootcache=False)[1])}"
 
 CONFIGURE_FILES = "${S}/configure.in ${S}/configure.ac ${S}/config.h.in ${S}/acinclude.m4 Makefile.am"