]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: fix build for shared object
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 28 May 2015 09:22:24 +0000 (02:22 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 30 May 2015 21:25:11 +0000 (22:25 +0100)
Fixed when build on armv7a_vfp_neon:
Python-3.3.3/Modules/_struct.o: relocation R_ARM_MOVW_ABS_NC against `a local symbol' can not be used when making a shared object; recompile with -fPIC

All the archs should use -fPIC when build shared object for linux.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3_3.4.3.bb

index bee9e6f8ecd189bc60f32aa56ed1db61f430de78..5ef17e639970bb3b5030bccc5a51531fdcb35465 100644 (file)
@@ -67,6 +67,7 @@ EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}
 export CROSS_COMPILE = "${TARGET_PREFIX}"
 export _PYTHON_PROJECT_BASE = "${B}"
 export _PYTHON_PROJECT_SRC = "${S}"
+export CCSHARED = "-fPIC"
 
 # No ctypes option for python 3
 PYTHONLSBOPTS = ""