]> code.ossystems Code Review - openembedded-core.git/commitdiff
elfutils: Fix size passed to snprintf for invalid sh_name case
authorZhenhua Luo <zhenhua.luo@freescale.com>
Tue, 12 Mar 2013 03:58:58 +0000 (11:58 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 15 Mar 2013 01:52:54 +0000 (01:52 +0000)
Following build error will appear on Fedora18.
nm.c: In function 'show_symbols_sysv':
nm.c:756:27: error: argument to 'sizeof' in 'snprintf' call is the same expression as the destination; did you mean to provide an explicit length? [-Werror=sizeof-pointer-memaccess]
    snprintf (name, sizeof name, "[invalid sh_name %#" PRIx32 "]",
                           ^

Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/elfutils/elfutils/nm-Fix-size-passed-to-snprintf-for-invalid-sh_name-case.patch [new file with mode: 0644]
meta/recipes-devtools/elfutils/elfutils_0.148.bb

diff --git a/meta/recipes-devtools/elfutils/elfutils/nm-Fix-size-passed-to-snprintf-for-invalid-sh_name-case.patch b/meta/recipes-devtools/elfutils/elfutils/nm-Fix-size-passed-to-snprintf-for-invalid-sh_name-case.patch
new file mode 100644 (file)
index 0000000..2b5dad3
--- /dev/null
@@ -0,0 +1,27 @@
+Upstream-Status: Backport
+
+nm: Fix size passed to snprintf for invalid sh_name case.
+native build failed as following on Fedora18:
+nm.c: In function 'show_symbols_sysv':
+nm.c:756:27: error: argument to 'sizeof' in 'snprintf' call is the same expression as the destination; did you mean to provide an explicit length? [-Werror=sizeof-pointer-memaccess]
+    snprintf (name, sizeof name, "[invalid sh_name %#" PRIx32 "]",
+                           ^
+
+The original commit is http://git.fedorahosted.org/cgit/elfutils.git/commit/src/nm.c?id=57bd66cabf6e6b9ecf622cdbf350804897a8df58
+
+Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
+
+--- elfutils-0.148/src/nm.c.org        2013-03-11 22:36:11.000000000 -0500
++++ elfutils-0.148/src/nm.c    2013-03-11 22:46:09.000000000 -0500
+@@ -752,8 +752,9 @@
+                              gelf_getshdr (scn, &shdr_mem)->sh_name);
+       if (unlikely (name == NULL))
+       {
+-        name = alloca (sizeof "[invalid sh_name 0x12345678]");
+-        snprintf (name, sizeof name, "[invalid sh_name %#" PRIx32 "]",
++        const size_t bufsz = sizeof "[invalid sh_name 0x12345678]";
++        name = alloca (bufsz);
++        snprintf (name, bufsz, "[invalid sh_name %#" PRIx32 "]",
+                   gelf_getshdr (scn, &shdr_mem)->sh_name);
+       }
+       scnnames[elf_ndxscn (scn)] = name;
index 45931b0ae980e8dd35890b7828696576d688718b..bc9e9c6ec2a8dfbb5df9d8841dc8e70e0d5d362d 100644 (file)
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3\
                     file://EXCEPTION;md5=570adcb0c1218ab57f2249c67d0ce417"
 DEPENDS = "libtool bzip2 zlib virtual/libintl"
 
-PR = "r9"
+PR = "r10"
 
 SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/elfutils-${PV}.tar.bz2"
 
@@ -31,6 +31,7 @@ SRC_URI += "\
        file://mempcpy.patch \
        file://fix_for_gcc-4.7.patch \
        file://dso-link-change.patch \
+       file://nm-Fix-size-passed-to-snprintf-for-invalid-sh_name-case.patch \
 "
 # Only apply when building uclibc based target recipe
 SRC_URI_append_libc-uclibc = " file://uclibc-support.patch"