]> code.ossystems Code Review - openembedded-core.git/commitdiff
unzip: fix symlink problem
authorRoss Burton <ross.burton@intel.com>
Wed, 25 Jul 2018 20:55:17 +0000 (21:55 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Aug 2018 14:22:26 +0000 (15:22 +0100)
Large zip files can cause unzip to crash, take a patch from Fedora to fix it.

(From OE-Core rev: a001833b7c7a0a6eef88e053fe65e2a0c91ca7bc)

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-extended/unzip/unzip/symlink.patch [new file with mode: 0644]
meta/recipes-extended/unzip/unzip_6.0.bb

diff --git a/meta/recipes-extended/unzip/unzip/symlink.patch b/meta/recipes-extended/unzip/unzip/symlink.patch
new file mode 100644 (file)
index 0000000..a38f6f1
--- /dev/null
@@ -0,0 +1,26 @@
+Unzip doesn't handle large zip files well and crashes:
+
+"This only happens if you have more then 16k entries and when one of
+the 16k entry infos is reused it happend to be previously used for
+a symlink entry."
+
+This patch is taken from Fedora (https://bugzilla.redhat.com/show_bug.cgi?id=972427)
+
+Upstream-Status: Pending (upstream is dead)
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+--- unzip60/process.c.sav      2013-06-09 12:08:57.070392264 +0200
++++ unzip60/process.c  2013-06-09 12:10:08.641696988 +0200
+@@ -1751,6 +1751,12 @@
+         = (G.crec.general_purpose_bit_flag & (1 << 11)) == (1 << 11);
+ #endif
++#ifdef SYMLINKS
++    /* Initialize the symlink flag, may be set by the platform-specific
++       mapattr function.  */
++    G.pInfo->symlink = 0;
++#endif 
++
+     return PK_COOL;
+ } /* end function process_cdir_file_hdr() */
index 105d048f55b29671f3986a7889eedb3e6b530f1f..dbf4112a4c6f9c3b4a1e54a5b45a11b4bb9146b3 100644 (file)
@@ -19,6 +19,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/infozip/UnZip%206.x%20%28latest%29/UnZip%206.0/
        file://fix-security-format.patch \
        file://18-cve-2014-9913-unzip-buffer-overflow.patch \
        file://19-cve-2016-9844-zipinfo-buffer-overflow.patch \
+       file://symlink.patch \
 "
 UPSTREAM_VERSION_UNKNOWN = "1"