]> code.ossystems Code Review - openembedded-core.git/commitdiff
qt4e-demo-image: Fix bug 999
authorXiaofeng Yan <xiaofeng.yan@windriver.com>
Fri, 26 Aug 2011 02:13:11 +0000 (10:13 +0800)
committerSaul Wold <sgw@linux.intel.com>
Fri, 26 Aug 2011 19:34:02 +0000 (12:34 -0700)
[YOCTO #999]
Copy metadata of qt4e-demo-image from OE for easy testing qt4embeded on embedded platform.
This image was tested on qemuarm and can run program "qtdemoE".

Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
meta/recipes-qt/images/qt4e-demo-image.bb [new file with mode: 0644]
meta/recipes-qt/tasks/task-qt4e.bb [new file with mode: 0644]

diff --git a/meta/recipes-qt/images/qt4e-demo-image.bb b/meta/recipes-qt/images/qt4e-demo-image.bb
new file mode 100644 (file)
index 0000000..f2150ca
--- /dev/null
@@ -0,0 +1,19 @@
+LICENSE = "MIT"
+PR="r1"
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+DEPENDS += "task-qt4e"
+
+RDEPENDS_${PN} += " \
+       task-qt4e-base \
+       "
+
+IMAGE_INSTALL += "\
+       module-init-tools \
+       task-qt4e-base \
+"
+
+inherit core-image
+
diff --git a/meta/recipes-qt/tasks/task-qt4e.bb b/meta/recipes-qt/tasks/task-qt4e.bb
new file mode 100644 (file)
index 0000000..c95c898
--- /dev/null
@@ -0,0 +1,56 @@
+DESCRIPTION = "QT4 Embedded base Image Feed"
+PR = "r1"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit task
+
+TOUCH = ' ${@base_contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
+
+PACKAGES += " \
+       ${PN}-base \
+"
+
+RDEPENDS_${PN}-base = " \
+       qt4-embedded \
+       libqt-embedded3support4 \
+       libqt-embeddedclucene4 \
+       libqt-embeddedcore4 \
+       libqt-embeddeddbus4 \
+       libqt-embeddedgui4 \
+       libqt-embeddedhelp4 \
+       libqt-embeddedmultimedia4 \
+       libqt-embeddednetwork4 \
+       libqt-embeddedscript4 \
+       libqt-embeddedscripttools4 \
+       libqt-embeddedsql4 \
+       libqt-embeddedsvg4 \
+       libqt-embeddedtest4 \
+       libqt-embeddedwebkit4 \
+       libqt-embeddedxml4 \
+       qt4-embedded-fonts-ttf-dejavu \
+       qt4-embedded-fonts-ttf-vera \
+       qt4-embedded-plugin-iconengine-svgicon \
+       qt4-embedded-plugin-imageformat-gif \
+       qt4-embedded-plugin-imageformat-ico \
+       qt4-embedded-plugin-imageformat-jpeg \
+       qt4-embedded-plugin-imageformat-mng \
+       qt4-embedded-plugin-imageformat-svg \
+       qt4-embedded-plugin-imageformat-tiff \
+       qt4-embedded-plugin-mousedriver-tslib \
+       qt4-embedded-plugin-phonon-backend-gstreamer \
+       qt4-embedded-plugin-script-dbus \
+       qt4-embedded-plugin-sqldriver-sqlite \
+       ${TOUCH} \
+        qt4-embedded-demos \
+        qt4-embedded-examples \
+        qt-demo-init \
+        qt4-embedded-assistant \
+"
+
+RRECOMMENDS_${PN}-base = " \
+       libqt-embeddedxmlpatterns4 \
+"
+