]> code.ossystems Code Review - openembedded-core.git/commitdiff
swig: Fix reproducibility issue
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 1 Mar 2021 00:11:10 +0000 (00:11 +0000)
committerSteve Sakoman <steve@sakoman.com>
Thu, 11 Mar 2021 15:00:02 +0000 (05:00 -1000)
Remove hardcoding the build configuration into the help/version output
from swig to make the binaries reproducible.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 7ed28ae9717ea9dad4e131012186d5f08e8f0bec)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-devtools/swig/swig/determinism.patch [new file with mode: 0644]
meta/recipes-devtools/swig/swig_3.0.12.bb

diff --git a/meta/recipes-devtools/swig/swig/determinism.patch b/meta/recipes-devtools/swig/swig/determinism.patch
new file mode 100644 (file)
index 0000000..8ffb4bc
--- /dev/null
@@ -0,0 +1,19 @@
+Remove the compiler commandline/platform from the compiled binary as this
+breaks reproducibilty.
+
+Upstream-Status: Inappropriate [OE reproducibiity fix upstream unlikely to take]
+RP 2021/3/1
+
+
+Index: swig-3.0.12/Source/Modules/main.cxx
+===================================================================
+--- swig-3.0.12.orig/Source/Modules/main.cxx
++++ swig-3.0.12/Source/Modules/main.cxx
+@@ -636,7 +636,6 @@ void SWIG_getoptions(int argc, char *arg
+       }
+       } else if (strcmp(argv[i], "-version") == 0) {
+       fprintf(stdout, "\nSWIG Version %s\n", Swig_package_version());
+-      fprintf(stdout, "\nCompiled with %s [%s]\n", SWIG_CXX, SWIG_PLATFORM);
+       fprintf(stdout, "\nConfigured options: %cpcre\n",
+ #ifdef HAVE_PCRE
+               '+'
index 45026c9700ba0737c4cf225bdac40c968dc75589..090aaa81127a656d58108c5dd6e6eab90e84b161 100644 (file)
@@ -6,6 +6,7 @@ SRC_URI += "file://0001-Use-proc-self-exe-for-swig-swiglib-on-non-Win32-plat.pat
             file://swig-3.0.12-Coverity-fix-issue-reported-for-SWIG_Python_FixMetho.patch \
             file://Python-Fix-new-GCC8-warnings-in-generated-code.patch \
             file://0001-Fix-generated-code-for-constant-expressions-containi.patch \
+            file://determinism.patch \
            "
 SRC_URI[md5sum] = "82133dfa7bba75ff9ad98a7046be687c"
 SRC_URI[sha256sum] = "7cf9f447ae7ed1c51722efc45e7f14418d15d7a1e143ac9f09a668999f4fc94d"