]> code.ossystems Code Review - openembedded-core.git/commitdiff
libcheck: split /usr/bin/checkmk into its own package
authorAlexander Kanavin <alex.kanavin@gmail.com>
Thu, 10 Oct 2019 11:18:43 +0000 (13:18 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 10 Oct 2019 15:55:54 +0000 (16:55 +0100)
This allows not pulling in gawk, which is gplv3 licensed when
only the libcheck library itself is needed. checkmk is a
development tool that writes out a C boilerplate for tests.

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libcheck/libcheck_0.12.0.bb

index 94b0dc1bbd1002628577c7b987b486e70e19ae54..25ac2c4b260395413543736a01b7756589ab86a4 100644 (file)
@@ -18,7 +18,12 @@ inherit autotools pkgconfig texinfo
 CACHED_CONFIGUREVARS += "ac_cv_path_AWK_PATH=${bindir}/gawk"
 
 RREPLACES_${PN} = "check (<= 0.9.5)"
-RDEPENDS_${PN} += "gawk"
-RDEPENDS_${PN}_class-native = ""
 
 BBCLASSEXTEND = "native nativesdk"
+
+PACKAGES =+ "checkmk"
+
+FILES_checkmk = "${bindir}/checkmk"
+
+RDEPENDS_checkmk = "gawk"
+