]> code.ossystems Code Review - openembedded-core.git/commitdiff
kmod: ptest fixes
authorTudor Florea <tudor.florea@enea.com>
Tue, 1 Oct 2013 22:54:40 +0000 (22:54 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 4 Oct 2013 17:25:38 +0000 (18:25 +0100)
 Make kmod-ptest able to compile with separated source and
 build dir. Since kmod test files contain kernel modules for
 many different architectures, strip and arch gets confused
 and throws errors.

Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Signed-off-by: Björn Stenberg <bjst@enea.com>
Signed-off-by: Maxin B. John <maxin.john@enea.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/kmod/kmod/ptest.patch
meta/recipes-kernel/kmod/kmod/run-ptest
meta/recipes-kernel/kmod/kmod_git.bb

index c6479b2fb5052a65ae0095017204dce83261b6cf..831dbcb909b7e448ac7356b6e3f5abc3af1ee2d2 100644 (file)
@@ -15,10 +15,10 @@ diff -ruN a/Makefile.am b/Makefile.am
 +      @for file in $(TESTSUITE); do \
 +              install $$file $(DESTDIR)/testsuite; \
 +      done;
-+      @cp Makefile $(DESTDIR)
-+      @sed -i 's/^Makefile/_Makefile/'  ${DESTDIR}/Makefile
-+      @tar -czf $(DESTDIR)/tools.tgz $(noinst_SCRIPTS) $(noinst_PROGRAMS)
-+      @tar -C testsuite -czf $(DESTDIR)/testsuite.tgz rootfs-pristine .libs
++      @sed -e 's/^Makefile/_Makefile/' < Makefile > $(DESTDIR)/Makefile
++      @$(MKDIR_P) $(DESTDIR)/tools
++      @cp $(noinst_SCRIPTS) $(noinst_PROGRAMS) $(DESTDIR)/tools
++      @cp -r testsuite/rootfs testsuite/.libs $(DESTDIR)/testsuite
 +
  # ------------------------------------------------------------------------------
  # custom release helpers
index fac24fd6e1723cf57fe46af3c55b3318dea3caf6..37adec3d2ff4fe9f88f3f5f9dfcda0f20421c63b 100755 (executable)
@@ -1,5 +1,3 @@
 #!/bin/sh
-tar -xzf tools.tgz
-tar -C testsuite -xzf testsuite.tgz
-make rootfs
+touch testsuite/stamp-rootfs
 make -k runtest-TESTS 2>/dev/null| grep -e ^PASS -e ^FAIL
index b07c06e7b46e6dc331ed80399513f1610dc3447e..ebecbcc82ee196f8ecd378638f1d1d010b40bcc0 100644 (file)
@@ -41,10 +41,12 @@ do_compile_prepend() {
 }
 
 do_compile_ptest () {
-        oe_runmake buildtest-TESTS
-        oe_runmake rootfs
+        oe_runmake buildtest-TESTS rootfs
 }
 
+INHIBIT_PACKAGE_STRIP = "${@base_contains("DISTRO_FEATURES", "ptest", "1", "0", d)}"
+INSANE_SKIP_${PN}-ptest = "arch"
+
 inherit update-alternatives
 
 ALTERNATIVE_PRIORITY = "60"