]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: Add python module packaging
authorRichard Purdie <richard@openedhand.com>
Mon, 6 Oct 2008 17:05:09 +0000 (17:05 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 6 Oct 2008 17:05:09 +0000 (17:05 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5423 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/rpm/rpm_4.4.2.3.bb

index ef6087893ca3024110787b0faf88eaf62bb2d3f3..3083387d87cff7b65e3d28476ef53adb5dae84c0 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "The RPM Package Manager."
 HOMEPAGE = "http://rpm.org/"
 LICENSE = "LGPL GPL"
 DEPENDS = "zlib beecrypt file popt python"
-PR = "r9"
+PR = "r10"
 
 SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \
            file://external-tools.patch;patch=1 \
@@ -20,13 +20,16 @@ acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
 
 EXTRA_OECONF = "--with-python=$PYTHONVER \
                --with-python-incdir=${STAGING_INCDIR}/python$PYTHONVER \
-               --with-python-libdir=${STAGING_LIBDIR}/python$PYTHONVER \
+               --with-python-libdir=${libdir}/python$PYTHONVER \
                --without-apidocs \
                --without-selinux \
                --without-lua \
                --without-dmalloc \
                --without-efence"
 
+PACKAGES += "python-rpm"
+FILES_python-rpm = "${libdir}/python*/site-packages/rpm/_*"
+
 # Handle the db MUTEX settings here, the POSIX library is
 # the default - "POSIX/pthreads/library".
 # Don't ignore the nice SWP instruction on the ARM: