]> code.ossystems Code Review - openembedded-core.git/commitdiff
man: fix src/Makefile to work with parallel make
authorBill Randle <william.c.randle@intel.com>
Tue, 29 Mar 2016 22:26:39 +0000 (15:26 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 29 Mar 2016 22:28:37 +0000 (23:28 +0100)
The Makefile for man has a rule to create two generated targets with
a program run from the shell. Because the rule was run twice, with
parallel make, the generated files were being overwritten at the same
time they were being compiled. This patch forces the rule to be run
only once.

[YOCTO #9333]

Signed-off-by: Bill Randle <william.c.randle@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/man/man/man-1.6g-parallel.patch [new file with mode: 0644]
meta/recipes-extended/man/man_1.6g.bb

diff --git a/meta/recipes-extended/man/man/man-1.6g-parallel.patch b/meta/recipes-extended/man/man/man-1.6g-parallel.patch
new file mode 100644 (file)
index 0000000..72a88b8
--- /dev/null
@@ -0,0 +1,30 @@
+The Makefile for man has a rule to create two generated targets with
+a program run from the shell. Because the rule was run twice, with
+parallel make, the generated files were being overwritten at the same
+time they were being compiled. This patch forces the rule to be run
+only once.
+
+Upstream-Status: Pending
+
+Signed-off-by: Bill Randle <william.c.randle at intel.com>
+
+--- man-1.6g/src/Makefile.in.orig      2010-12-31 12:28:46.000000000 -0800
++++ man-1.6g/src/Makefile.in   2016-03-28 09:09:16.845458798 -0700
+@@ -43,8 +43,10 @@
+ makemsg:
+       $(BUILD_CC) -o makemsg makemsg.c
+-msg.c gripedefs.h: ../msgs/mess.en makemsg
++msg.c gripedefs.h: genfiles-stamp
++genfiles-stamp: ../msgs/mess.en makemsg
+       ./makemsg ../msgs/mess.en gripedefs.h msg.c
++      touch genfiles-stamp
+ # glob.c does not have prototypes
+ glob.o: glob.c ndir.h
+@@ -117,4 +119,4 @@
+ spotless: clean
+       rm -f Makefile config.status paths.h version.h man.conf
+-      rm -f gripedefs.h msg.c mess.*.cat
++      rm -f gripedefs.h msg.c mess.*.cat genfiles-stamp
index fa4736b298ae30968ffe64b0a9f1a7f067ec48c7..9b057b65737a004f642c870fbbf2fcfdfb177e97 100644 (file)
@@ -53,6 +53,7 @@ SRC_URI = "http://pkgs.fedoraproject.org/lookaside/pkgs/man2html/${BP}.tar.gz/ba
            file://manpath.5.gz;unpack=false \
            file://man-1.6g-whatis3.patch \
            file://configure_sed.patch \
+           file://man-1.6g-parallel.patch \
 "
 
 SRC_URI[md5sum] = "ba154d5796928b841c9c69f0ae376660"