]> code.ossystems Code Review - openembedded-core.git/commitdiff
u-boot: update to version 2015.01
authorDenys Dmytriyenko <denys@ti.com>
Tue, 10 Feb 2015 18:56:00 +0000 (13:56 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 14 Feb 2015 08:40:35 +0000 (08:40 +0000)
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-bsp/u-boot/u-boot-fw-utils/0001-tools-env-fix-build-error.patch [new file with mode: 0644]
meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb [moved from meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb with 56% similarity]
meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb [deleted file]
meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb [new file with mode: 0644]
meta/recipes-bsp/u-boot/u-boot.inc
meta/recipes-bsp/u-boot/u-boot_2015.01.bb [moved from meta/recipes-bsp/u-boot/u-boot_2014.07.bb with 50% similarity]

diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils/0001-tools-env-fix-build-error.patch b/meta/recipes-bsp/u-boot/u-boot-fw-utils/0001-tools-env-fix-build-error.patch
new file mode 100644 (file)
index 0000000..381b505
--- /dev/null
@@ -0,0 +1,36 @@
+From ee2d75513452aa6d5306fd380104adc8a2f6d8f2 Mon Sep 17 00:00:00 2001
+From: Masahiro Yamada <yamada.m@jp.panasonic.com>
+Date: Wed, 3 Dec 2014 10:22:50 +0900
+Subject: [PATCH] tools: env: fix build error
+
+Since CONFIG_SYS_ARCH, CONFIG_SYS_CPU, ... were moved to Kconfig,
+tools/env/fw_printenv fails to build if CONFIG_ENV_VARS_UBOOT_CONFIG
+is defined.
+(I do not think this is the right way to fix the problem, but
+for now I do not have enough time to take a close look.)
+
+Upstream-Status: Submitted [http://patchwork.ozlabs.org/patch/417192/]
+
+Signed-off-by: Masahiro Yamada <yamada.m@jp.panasonic.com>
+Reported-by: Denys Dmytriyenko <denys@ti.com>
+---
+ tools/env/fw_env.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/tools/env/fw_env.c b/tools/env/fw_env.c
+index 1173eea..698fe51 100644
+--- a/tools/env/fw_env.c
++++ b/tools/env/fw_env.c
+@@ -8,6 +8,9 @@
+  * SPDX-License-Identifier:   GPL-2.0+
+  */
++/* FIXME: Do not include this */
++#include <linux/kconfig.h>
++
+ #include <errno.h>
+ #include <env_flags.h>
+ #include <fcntl.h>
+-- 
+2.2.0
+
similarity index 56%
rename from meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
rename to meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb
index 9a304c8c5d724b4b00ac9e53746a51c02dc3e1dd..2b0550cb37a60a048105c97d0f7f70d2ccb00a2b 100644 (file)
@@ -1,21 +1,24 @@
 SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
 LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
 SECTION = "bootloader"
 DEPENDS = "mtd-utils"
 
-# This revision corresponds to the tag "v2014.07"
+# This revision corresponds to the tag "v2015.01"
 # We use the revision in order to avoid having to fetch it from the
 # repo during parse
-SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959"
+SRCREV = "92fa7f53f1f3f03296f8ffb14bdf1baefab83368"
 
-PV = "v2014.07+git${SRCPV}"
+PV = "v2015.01+git${SRCPV}"
 
-SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git \
+           file://0001-tools-env-fix-build-error.patch"
 
 S = "${WORKDIR}/git"
 
 INSANE_SKIP_${PN} = "already-stripped"
+EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
 
 inherit uboot-config
 
@@ -33,14 +36,14 @@ do_install () {
 }
 
 do_install_class-cross () {
-    install -d ${D}${bindir_cross}
-    install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
-    install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
+       install -d ${D}${bindir_cross}
+       install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+       install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
 }
 
 SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
 uboot_fw_utils_cross() {
-    sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
+       sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
 }
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb
deleted file mode 100644 (file)
index eabf680..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-SUMMARY = "U-Boot bootloader image creation tool"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
-SECTION = "bootloader"
-
-# This revision corresponds to the tag "v2014.07"
-# We use the revision in order to avoid having to fetch it from the
-# repo during parse
-SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959"
-
-PV = "v2014.07+git${SRCPV}"
-
-SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
-
-do_compile () {
-       # Make sure the recompile is OK
-       rm -f ${B}/tools/.depend
-
-       make HOSTCC="${BUILD_CC}" HOSTLD="${BUILD_LD}" HOSTLDFLAGS="${BUILD_LDFLAGS}" HOSTSTRIP=true dot-config=0 scripts_basic
-       sed 's/^tools-only: scripts_basic /tools-only: /' -i Makefile
-       oe_runmake tools-only
-}
-
-do_install () {
-       install -d ${D}${bindir}
-       install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
-       ln -sf uboot-mkimage ${D}${bindir}/mkimage
-}
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb
new file mode 100644 (file)
index 0000000..57989c7
--- /dev/null
@@ -0,0 +1,32 @@
+SUMMARY = "U-Boot bootloader image creation tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
+SECTION = "bootloader"
+
+DEPENDS = "openssl"
+
+# This revision corresponds to the tag "v2015.01"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "92fa7f53f1f3f03296f8ffb14bdf1baefab83368"
+
+PV = "v2015.01+git${SRCPV}"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
+
+do_compile () {
+       oe_runmake sandbox_defconfig
+       oe_runmake cross_tools NO_SDL=1
+}
+
+do_install () {
+       install -d ${D}${bindir}
+       install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+       ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
+BBCLASSEXTEND = "native nativesdk"
index b898d6a34de8bc2e34571e45de1deaa9c2b9626c..6bdc86ae0cdff4200ff8f269119334d76258573a 100644 (file)
@@ -4,7 +4,7 @@ SECTION = "bootloaders"
 PROVIDES = "virtual/bootloader"
 
 LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
 
 SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
 
@@ -14,7 +14,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 inherit uboot-config deploy
 
-EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
+EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" V=1'
 
 # Allow setting an additional version string that will be picked up by the
 # u-boot build system and appended to the u-boot version.  If the .scmversion
similarity index 50%
rename from meta/recipes-bsp/u-boot/u-boot_2014.07.bb
rename to meta/recipes-bsp/u-boot/u-boot_2015.01.bb
index 44cc52eb6c767b38875e94319a365062bec124fd..6feac3107d68326ecf1e6392f0d1e83291443a71 100644 (file)
@@ -2,8 +2,8 @@ require u-boot.inc
 
 DEPENDS += "dtc-native"
 
-# This revision corresponds to the tag "v2014.07"
+# This revision corresponds to the tag "v2015.01"
 # We use the revision in order to avoid having to fetch it from the repo during parse
-SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959"
+SRCREV = "92fa7f53f1f3f03296f8ffb14bdf1baefab83368"
 
-PV = "v2014.07+git${SRCPV}"
+PV = "v2015.01+git${SRCPV}"