]> code.ossystems Code Review - openembedded-core.git/commitdiff
docbook-dsssl-stylesheets-native: run install-catalog only during do_populate_sysroot
authorScott Garman <scott.a.garman@intel.com>
Mon, 4 Apr 2011 20:09:26 +0000 (13:09 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 4 Apr 2011 22:45:28 +0000 (23:45 +0100)
Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb

index fc4d266a9c82267e8061f0fc2e31265d8c04f005..88d24dd949b48a621076c65a62fdae38a80a900e 100644 (file)
@@ -38,9 +38,12 @@ do_install () {
 }
 
 docbook_dsssl_stylesheets_sstate_postinst () {
-       # Ensure that the catalog file sgml-docbook.cat is properly
-       # updated when the package is installed from sstate cache.
-       install-catalog \
-               --add ${sysconfdir}/sgml/sgml-docbook.cat \
-               ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat
+       if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
+       then
+               # Ensure that the catalog file sgml-docbook.cat is properly
+               # updated when the package is installed from sstate cache.
+               install-catalog \
+                       --add ${sysconfdir}/sgml/sgml-docbook.cat \
+                       ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat
+       fi
 }