]> code.ossystems Code Review - openembedded-core.git/commitdiff
base-passwd: Don't replace $ variables in passwd and group files
authorPascal Bach <pascal.bach@siemens.com>
Wed, 21 Jan 2015 19:30:25 +0000 (11:30 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 28 Jan 2015 21:22:22 +0000 (21:22 +0000)
This allows the usage of "$type$salt$encrypted_password" passwords in the passwd file.

Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/base-passwd/base-passwd_3.5.29.bb

index ec8f2afb2259cd092b4d7c67f164d9f3155d9b6a..a35ea9bd08243a11424388911fbb11644748c8ee 100644 (file)
@@ -75,11 +75,11 @@ python populate_packages_prepend() {
     preinst = """#!/bin/sh
 mkdir -p $D${sysconfdir}
 if [ ! -e $D${sysconfdir}/passwd ]; then
-\tcat << EOF > $D${sysconfdir}/passwd
+\tcat << 'EOF' > $D${sysconfdir}/passwd
 """ + passwd + """EOF
 fi
 if [ ! -e $D${sysconfdir}/group ]; then
-\tcat << EOF > $D${sysconfdir}/group
+\tcat << 'EOF' > $D${sysconfdir}/group
 """ + group + """EOF
 fi
 """