]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnome-vfs: Force acl to be disabled since its not a dependency
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 17 Mar 2011 12:30:57 +0000 (12:30 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 17 Mar 2011 12:31:38 +0000 (12:31 +0000)
Without this patch, if acl was build beforehand, the build could find
the library resulting in a non-deterministic build.

Sadly there is no --disable or --without option available so this
approach is the only mechanism available.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/gnome/gnome-vfs_2.24.4.bb

index 0c307daeaeb03b15ca7dbc5f4b9d7596c04206d7..3ca9c568eea883939ee630144289567448d20a02 100644 (file)
@@ -26,10 +26,13 @@ SRC_URI += "file://gconftool-lossage.patch;patch=1;pnum=1 \
 SRC_URI[archive.md5sum] = "a05fab03eeef10a47dd156b758982f2e"
 SRC_URI[archive.sha256sum] = "62de64b5b804eb04104ff98fcd6a8b7276d510a49fbd9c0feb568f8996444faa"
 
-EXTRA_OECONF = " \
-                 --disable-hal \
-                --disable-openssl \
-                --disable-samba \
+EXTRA_OECONF = " --disable-hal \
+                 --disable-openssl \
+                 --disable-samba \
+                 ac_cv_lib_acl_acl_get_file=no \
+                 ac_cv_lib_sec_acl=no \
+                 gvfs_cv_HAVE_SOLARIS_ACLS=no \
+                 gvfs_cv_HAVE_POSIX_ACLS=no \
                 "
 
 FILES_${PN} += " ${libdir}/vfs ${datadir}/dbus-1/services"