]> code.ossystems Code Review - openembedded-core.git/commitdiff
automake: Sync with OE
authorRichard Purdie <richard@openedhand.com>
Tue, 9 May 2006 17:41:37 +0000 (17:41 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 9 May 2006 17:41:37 +0000 (17:41 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@382 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/automake/automake-native.inc
openembedded/packages/automake/automake.inc [new file with mode: 0644]
openembedded/packages/automake/automake_1.9.3.bb

index 9e89ac86218c9e7f6eac73dc2551055d4fb02d8d..7b69252ff0a00519e452cb7a3c750e81c58c685d 100644 (file)
@@ -1,7 +1,7 @@
 SECTION = "devel"
 include automake_${PV}.bb
 DEPENDS = "autoconf-native"
-RDEPENDS_${PN} = "autoconf-native perl-native-runtime"
+RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
 
 inherit native
 
diff --git a/openembedded/packages/automake/automake.inc b/openembedded/packages/automake/automake.inc
new file mode 100644 (file)
index 0000000..fa59c1f
--- /dev/null
@@ -0,0 +1,23 @@
+RDEPENDS_automake += "\
+    autoconf \
+    perl \
+    perl-module-bytes \
+    perl-module-constant \
+    perl-module-cwd \
+    perl-module-data-dumper \
+    perl-module-dynaloader \
+    perl-module-errno \
+    perl-module-exporter-heavy \
+    perl-module-file-basename \
+    perl-module-file-compare \
+    perl-module-file-copy \
+    perl-module-file-glob \
+    perl-module-file-spec-unix \
+    perl-module-file-stat \
+    perl-module-getopt-long \
+    perl-module-io \
+    perl-module-io-file \
+    perl-module-posix \
+    perl-module-strict \
+    perl-module-text-parsewords \
+    perl-module-vars "
index 71bf0bd58bbfa1c39a5d82679279d2847f790c1c..fb75b83b68d1c93532b46cbe0f2bea29d4e91701 100644 (file)
@@ -13,7 +13,8 @@ inherit autotools
 
 export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
 FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
-RDEPENDS_${PN} += "autoconf perl"
+
+include automake.inc
 
 do_install () {
        oe_runmake 'DESTDIR=${D}' install