]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-libc-headers-yocto: remove from oe-core
authorBruce Ashfield <bruce.ashfield@windriver.com>
Fri, 23 Mar 2012 17:07:48 +0000 (13:07 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 23 Mar 2012 17:38:21 +0000 (17:38 +0000)
The linux-libc-headers-yocto is not required in oe-core, it can be
moved to yocto specific layers. The linux-libc-headers_* recipes
provide sufficient headers fore core users.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb [deleted file]

diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
deleted file mode 100644 (file)
index 7aa9322..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-require linux-libc-headers.inc
-include recipes-kernel/linux/linux-yocto.inc
-
-B = "${S}"
-
-INHIBIT_DEFAULT_DEPS = "1"
-DEPENDS += "unifdef-native"
-PROVIDES = "linux-libc-headers"
-RPROVIDES_${PN}-dev = "linux-libc-headers-dev"
-RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg"
-SRCREV = "21ab5dca134a6bf1316aa59f69f9ee9e091d5702"
-KBRANCH ?= "standard/base"
-KMETA ?= "meta"
-PV = "3.2+git-${SRCPV}"
-PR = "r5"
-
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
-
-# force this to empty to prevent installation failures, we aren't
-# building a device tree as part of kern headers
-KERNEL_DEVICETREE = ""
-
-set_arch() {
-       case ${TARGET_ARCH} in
-               arm*)     ARCH=arm ;;
-               i*86*)    ARCH=i386 ;;
-               ia64*)    ARCH=ia64 ;;
-               mips*)    ARCH=mips ;;
-               powerpc*) ARCH=powerpc ;;
-               x86_64*)  ARCH=x86_64 ;;
-       esac
-}
-
-do_configure() {
-       set_arch
-       oe_runmake allnoconfig ARCH=$ARCH
-}
-
-do_install() {
-       set_arch
-       oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
-
-        # The ..install.cmd conflicts between various configure runs
-        find ${D}${includedir} -name ..install.cmd | xargs rm -f
-}
-
-# The following tasks are not required when we just want
-# headers. So we override and stub them out.
-do_kernel_configme() {
-}
-
-do_patch () {
-}
-
-do_compile () {
-}
-
-do_validate_branches () {
-}
-
-do_kernel_configcheck () {
-}
-
-BBCLASSEXTEND = "nativesdk"