]> code.ossystems Code Review - openembedded-core.git/commitdiff
irda-utils: Weak Define the build TARGETS
authorKhem Raj <raj.khem@gmail.com>
Mon, 31 Aug 2015 06:17:20 +0000 (06:17 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 12 Sep 2015 21:47:12 +0000 (22:47 +0100)
This will help one to disable the targets via bbappends if needed
e.g. musl can not compile irdaping since it uses includes
net/if_packet.h, which (on GLIBC) only defines struct sockaddr_pkt but
not in other libc e.g. musl that makes irdaping specific to glibc

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-connectivity/irda-utils/irda-utils_0.9.18.bb

index bd60b9f1e6542d607bf110a4138bdd58fae1260a..8ac3b18697b57e0f0d3fd167de780067b415e3ed 100644 (file)
@@ -32,15 +32,18 @@ EXTRA_OEMAKE = "\
 INITSCRIPT_NAME = "irattach"
 INITSCRIPT_PARAMS = "defaults 20"
 
+TARGETS ??= "irattach irdaping"
 do_compile () {
-       oe_runmake -C irattach
-       oe_runmake -C irdaping
+       for t in ${TARGETS}; do
+               oe_runmake -C $t
+       done
 }
 
 do_install () {
        install -d ${D}${sbindir}
-       oe_runmake -C irattach ROOT="${D}" install
-       oe_runmake -C irdaping ROOT="${D}" install
+       for t in ${TARGETS}; do
+               oe_runmake -C $t ROOT="${D}" install
+       done
 
        install -d ${D}${sysconfdir}/init.d
        install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}