]> code.ossystems Code Review - openembedded-core.git/commitdiff
u-boot-tools: backport patch from upstream to fix gcc 10 builds
authorSteve Sakoman <steve@sakoman.com>
Wed, 17 Jun 2020 22:43:09 +0000 (12:43 -1000)
committerSteve Sakoman <steve@sakoman.com>
Thu, 18 Jun 2020 14:34:55 +0000 (04:34 -1000)
meta/recipes-bsp/u-boot/u-boot-tools/remove-redundant-yyloc-global.patch [new file with mode: 0644]
meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb

diff --git a/meta/recipes-bsp/u-boot/u-boot-tools/remove-redundant-yyloc-global.patch b/meta/recipes-bsp/u-boot/u-boot-tools/remove-redundant-yyloc-global.patch
new file mode 100644 (file)
index 0000000..2a184e5
--- /dev/null
@@ -0,0 +1,27 @@
+From 018921ee79d3f30893614b3b2b63b588d8544f73 Mon Sep 17 00:00:00 2001
+From: Peter Robinson <pbrobinson@gmail.com>
+Date: Thu, 30 Jan 2020 09:37:15 +0000
+Subject: [PATCH] Remove redundant YYLOC global declaration
+
+Same as the upstream fix for building dtc with gcc 10.
+
+Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
+---
+ scripts/dtc/dtc-lexer.l | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/scripts/dtc/dtc-lexer.l b/scripts/dtc/dtc-lexer.l
+index fd825ebba6..24af549977 100644
+--- a/scripts/dtc/dtc-lexer.l
++++ b/scripts/dtc/dtc-lexer.l
+@@ -38,7 +38,6 @@ LINECOMMENT  "//".*\n
+ #include "srcpos.h"
+ #include "dtc-parser.tab.h"
+-YYLTYPE yylloc;
+ extern bool treesource_error;
+ /* CAUTION: this will stop working if we ever use yyless() or yyunput() */
+-- 
+2.26.2
+
index 7eaf721ca837ab834b963d34982ebc0de1de7305..ca8876ff986be95faeffe69032ac9196dd781993 100644 (file)
@@ -1,2 +1,4 @@
 require u-boot-common.inc
 require u-boot-tools.inc
+
+SRC_URI += "file://remove-redundant-yyloc-global.patch"