]> code.ossystems Code Review - openembedded-core.git/commitdiff
openjade-native: run install-catalog only during do_populate_sysroot
authorScott Garman <scott.a.garman@intel.com>
Mon, 4 Apr 2011 20:07:17 +0000 (13:07 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 4 Apr 2011 22:45:20 +0000 (23:45 +0100)
Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-devtools/openjade/openjade-native_1.3.2.bb

index 5c1037a5de67d943cb04c32ebf4cd5e8e3b2154f..1c672e109e1bae8f31920d1c73f0ad00bb9c1bb5 100644 (file)
@@ -62,9 +62,12 @@ do_install() {
 }
 
 openjade_sstate_postinst() {
-       # Ensure that the catalog file sgml-docbook.cat is properly
-       # updated when the package is installed from sstate cache.
-       install-catalog \
-               --add ${sysconfdir}/sgml/sgml-docbook.cat \
-               ${sysconfdir}/sgml/openjade-${PV}.cat
+       if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
+       then
+               # Ensure that the catalog file sgml-docbook.cat is properly
+               # updated when the package is installed from sstate cache.
+               install-catalog \
+                       --add ${sysconfdir}/sgml/sgml-docbook.cat \
+                       ${sysconfdir}/sgml/openjade-${PV}.cat
+       fi
 }