]> code.ossystems Code Review - openembedded-core.git/commitdiff
ltp: fix makefile race
authorRoss Burton <ross.burton@intel.com>
Wed, 15 Jan 2014 14:10:54 +0000 (14:10 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 15 Jan 2014 17:26:38 +0000 (17:26 +0000)
There is a Makefile dependency race causing occasional build failures:

*** No rule to make target `.../work/core2-poky-linux/ltp/20130904-r0/git/testcases/kernel/include/linux_syscall_numbers.h.23161.sh', needed by `linux_syscall_numbers.h'.  Stop.

This is due to a bad dependency wildcard that is matching more than the one file
it should match, so replace it with a concrete filename.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/ltp/ltp/regen-makefile.patch [new file with mode: 0644]
meta/recipes-extended/ltp/ltp_20130904.bb

diff --git a/meta/recipes-extended/ltp/ltp/regen-makefile.patch b/meta/recipes-extended/ltp/ltp/regen-makefile.patch
new file mode 100644 (file)
index 0000000..3e114a1
--- /dev/null
@@ -0,0 +1,22 @@
+Fix the dependencies for linux_syscall_numbers.h where in a parallel build it was
+finding the temporary file linux_syscall_numbers.h.[pid].sh (where sh is an
+architecture name).  Instead don't wildcard *.sh as the only .sh we care about
+here is regen.sh, so hard-code that.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/testcases/kernel/include/Makefile b/testcases/kernel/include/Makefile
+index db21a2a..585eb5e 100644
+--- a/testcases/kernel/include/Makefile
++++ b/testcases/kernel/include/Makefile
+@@ -28,7 +28,7 @@ INSTALL_DIR          := $(includedir)
+ MAKE_TARGETS          := linux_syscall_numbers.h
+-linux_syscall_numbers.h: $(wildcard $(abs_srcdir)/*.sh $(abs_srcdir)/*.in)
+-      $(SHELL) "$(abs_srcdir)/regen.sh"
++linux_syscall_numbers.h: $(abs_srcdir)/regen.sh $(wildcard $(abs_srcdir)/*.in)
++      $(SHELL) "$<"
+ include $(top_srcdir)/include/mk/generic_leaf_target.mk
index 4722a38bceb39acf6c15b3b01cf47220d02f4e7c..c346c5ccb87ee165fd70ce31e3ae64027dabb0a0 100644 (file)
@@ -23,6 +23,7 @@ DEPENDS = "attr libaio libcap acl openssl"
 
 SRC_URI = "git://github.com/linux-test-project/ltp.git \
            file://0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch \
+           file://regen-makefile.patch \
 "
 
 SRCREV = "a8c42db5f9314211811c36275a21f83902830dc5"