]> code.ossystems Code Review - openembedded-core.git/commitdiff
core-image-sato-sdk-ptest: Tweak size to stay within 4GB limit
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 15 May 2019 14:45:14 +0000 (15:45 +0100)
committerArmin Kuster <akuster808@gmail.com>
Sat, 1 Jun 2019 21:48:32 +0000 (14:48 -0700)
Adding the valgrind debug symbol information caused the genericx86-64 image to
overflow the 4GB boundary. Tweak the sizes to avoid autobuilder failures yet
leave enough space all the tests still run successfully.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-sato/images/core-image-sato-sdk-ptest.bb

index 57395992cc26de52909d8c4b48da5060f5d5bd88..22df057947a9d65f6d4a14799c04dfa445ffb40c 100644 (file)
@@ -6,10 +6,10 @@ IMAGE_FEATURES += "ptest-pkgs"
 
 # This image is sufficiently large (~1.8GB) that we need to be careful that it fits in a live
 # image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
-# box) and explicitly add just 1300MB.
+# box) and explicitly add just 1200MB.
 # strace-ptest in particular needs more than 500MB
 IMAGE_OVERHEAD_FACTOR = "1.0"
-IMAGE_ROOTFS_EXTRA_SPACE = "1324288"
+IMAGE_ROOTFS_EXTRA_SPACE = "1224288"
 
 # ptests need more memory than standard to avoid the OOM killer
 QB_MEM = "-m 1024"