]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub-efi: Use a variable to specify built-in grub modules.
authorPhilip Tricca <flihp@twobit.us>
Wed, 16 Apr 2014 01:16:48 +0000 (01:16 +0000)
committerSaul Wold <sgw@linux.intel.com>
Fri, 23 May 2014 16:09:39 +0000 (09:09 -0700)
The previous behavior defines a static set of modules that are built
into the grub efi executable. This works fine for a limited set of boot
environments namely the standard linux/initrd. This patch conditionally
 assigns the same modules to a variable. This allows other meta layers
to add additional modules or completely override the defaults. The use
case driving this patch is the use of multiboot2 and related modules.

(From OE-Core rev: 597f8e0040ba3135220000b23767858c64b5c9b8)

Signed-off-by: Philip Tricca <flihp@twobit.us>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/grub/grub-efi_2.00.bb

index 6944cb280e9bd981989238dbd0d0b7acc0459625..4b43749200e21a321a26bfbf9e11233c1c2b890e 100644 (file)
@@ -70,12 +70,14 @@ do_install_class-native() {
        install -m 755 grub-mkimage ${D}${bindir}
 }
 
+GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search"
+
 do_deploy() {
        # Search for the grub.cfg on the local boot media by using the
        # built in cfg file provided via this recipe
        grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
                       -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
-                      boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search
+                      ${GRUB_BUILDIN}
        install -m 644 ${B}/${GRUB_IMAGE} ${DEPLOYDIR}
 }