]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/3.10: enable CONFIG_FHANDLE for standard and preempt-rt kernels
authorBruce Ashfield <bruce.ashfield@windriver.com>
Fri, 14 Feb 2014 19:13:57 +0000 (14:13 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 14 Feb 2014 22:52:56 +0000 (22:52 +0000)
    CONFIG_FHANDLE is now a requirement for systemd support:

      http://cgit.freedesktop.org/systemd/systemd/commit/README?id=c2cb7cbbd526e572b1caa1d7f70be68195b513a9

    So we add it into our default standard and preempt-rt kernel types, the
    overhead is small and having this always configured allows init system
    switching, without a kernel rebuild.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
meta/recipes-kernel/linux/linux-yocto_3.10.bb

index b5bde68cfd3cfbad29e4901ac41e296889013783..5e56b4c161217e27d42a95643bc1f944987d6310 100644 (file)
@@ -5,7 +5,7 @@ KBRANCH_qemuppc = "standard/preempt-rt/qemuppc"
 
 SRCREV_machine ?= "f17f18f928d3af8b18b69fdf224b3e4ed86dbfbf"
 SRCREV_machine_qemuppc ?= "82c9f3bfe1c97ba8b653bff8d4e030cf54bc1de7"
-SRCREV_meta ?= "d57f7367a5f44a47b84425bb48601b41c6d0ed8a"
+SRCREV_meta ?= "8f8af5a3b1cd4ea4ec76e0db763efeb3807ad76c"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
 
index 48d6082a6b14db06c545e6d25e50484604a9c8b4..a987022ddce06ab15e0549d2dda807ab90c74e52 100644 (file)
@@ -10,7 +10,7 @@ LINUX_VERSION ?= "3.10.28"
 KMETA = "meta"
 
 SRCREV_machine ?= "3e0a296fae952d8d93eb0f96566bf6d4a978c8ee"
-SRCREV_meta ?= "d57f7367a5f44a47b84425bb48601b41c6d0ed8a"
+SRCREV_meta ?= "8f8af5a3b1cd4ea4ec76e0db763efeb3807ad76c"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index 32d5fee02186f048328c65b97a9f2af68837f686..efbf24d3b3aa030966f47729c22124ec919fd773 100644 (file)
@@ -18,7 +18,7 @@ SRCREV_machine_qemux86 ?= "3e0a296fae952d8d93eb0f96566bf6d4a978c8ee"
 SRCREV_machine_qemux86-64 ?= "3e0a296fae952d8d93eb0f96566bf6d4a978c8ee"
 SRCREV_machine_qemumips64 ?= "fe1fab7061b8369deca03b2ec59f186bdbe2b8d9"
 SRCREV_machine ?= "3e0a296fae952d8d93eb0f96566bf6d4a978c8ee"
-SRCREV_meta ?= "d57f7367a5f44a47b84425bb48601b41c6d0ed8a"
+SRCREV_meta ?= "8f8af5a3b1cd4ea4ec76e0db763efeb3807ad76c"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"