]> code.ossystems Code Review - openembedded-core.git/commitdiff
fic-gta01: sync with OE
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 7 Nov 2007 17:25:50 +0000 (17:25 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 7 Nov 2007 17:25:50 +0000 (17:25 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3098 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/conf/machine/fic-gta01.conf

index d0e62e0a44b9affce86188c66479e8c5130df8b2..bd14df5814adceff7906aec52046dc109a620613 100644 (file)
@@ -1,33 +1,48 @@
 #-----------------------------------------------------------------------------
 #@TYPE: Machine
 #@NAME: FIC GTA01 (Neo1973)
-#@DESCRIPTION: Machine configuration for the FIC Neo1973 GSM phone
+#@DESCRIPTION: Machine configuration for the FIC Neo1973/1 GSM phone
 #-----------------------------------------------------------------------------
 
 TARGET_ARCH = "arm"
-PACKAGE_EXTRA_ARCHS = "armv4t"
+MACHINE_CLASS = "neo1973"
+PACKAGE_EXTRA_ARCHS = "armv4t ${MACHINE_CLASS}"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-openmoko"
+UBOOT_ENTRYPOINT = "30008000"
 
-MACHINE_FEATURES = "kernel26 apm alsa bluetooth usbgadget phone usbhost"
+MACHINE_FEATURES = "kernel26 apm alsa bluetooth gps usbgadget usbhost phone"
+MACHINE_DISPLAY_WIDTH_PIXELS = "480"
+MACHINE_DISPLAY_HEIGHT_PIXELS = "640"
+MACHINE_DISPLAY_ORIENTATION = "0"
+MACHINE_DISPLAY_PPI = "285"
 
+# package machine specific modules
 MACHINE_EXTRA_RRECOMMENDS = "\
-  usbinit \
   kernel-module-gta01-pm-bt  \
   kernel-module-gta01-pm-gps \
   kernel-module-gta01-pm-gsm \
   kernel-module-gta01kbd \
   kernel-module-s3cmci \
-  kernel-module-ext2 "
-
-# used by sysvinit_2
+  kernel-module-ext2 \
+  kernel-module-vfat \
+  kernel-module-snd-soc-neo1973-wm8753 \
+  kernel-module-snd-soc-smdk2440 \
+  kernel-module-nls-iso8859-1 \
+  kernel-module-nls-cp437 \
+"
+
+# do not outcomment, we bypass the sysvinit.bb logic here -- see FIC GTA01 inittab
 #SERIAL_CONSOLE = "115200 ttySAC0"
 
 # used by some images
 ROOT_FLASH_SIZE = "60"
 
 # extra jffs2 tweaks
-EXTRA_IMAGECMD_jffs2 = "--eraseblock=0x4000 -n -x lzo"
+EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x4000 --pad -n"
+
+# build / upload tools
+EXTRA_IMAGEDEPENDS += "dfu-util-native"
 
 # tune for S3C24x0
 include conf/machine/include/tune-arm920t.inc