]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxcrypt: Switch to disable obsolete APIs
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 19 Jun 2019 13:49:36 +0000 (14:49 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 19 Jun 2019 13:56:07 +0000 (14:56 +0100)
Since we have a fair amount of control of what we build in OE we can disable the obsolete
APIs which is what most distros are doing at this point.

This causes the library version to bump from 1 to 2.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb

index 637c0e6ffbddbce5b330c0acade572df6f78fb16..893f5e7379191b24094966f9bae31ba0985d7de7 100644 (file)
@@ -29,4 +29,7 @@ BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
 TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error=missing-attributes"
 CPPFLAGS_append_class-nativesdk = " -Wno-error=missing-attributes"
 
+API = "--disable-obsolete-api"
+EXTRA_OECONF += "${API}"
+
 BBCLASSEXTEND = "nativesdk"