]> code.ossystems Code Review - openembedded-core.git/commitdiff
bitbake: create cooker object after cleaning the environment
authorJeff Dike <jdike@linux.intel.com>
Tue, 29 Jun 2010 12:33:24 +0000 (13:33 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 29 Jun 2010 12:33:24 +0000 (13:33 +0100)
Previously, the cooker object was created before the environment was
cleaned, saving everything that was in the environment and dumping
into the run scripts.

The patch ensures that the cooker gets a cleaned environment when it's
created.

Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
bitbake/bin/bitbake

index 0f4ff88171bbbb12a7c4683a0e63b93f651ce461..6d74e5b85d47b18a2c36301b66cf5e4feee92dd9 100755 (executable)
@@ -155,13 +155,13 @@ Default BBFILES are the .bb files in the current directory.""" )
     bb.utils.init_logger(bb.msg, configuration.verbose, configuration.debug,
                          configuration.debug_domains)
 
-    cooker = bb.cooker.BBCooker(configuration, server)
-
     # Clear away any spurious environment variables. But don't wipe the
     # environment totally. This is necessary to ensure the correct operation
     # of the UIs (e.g. for DISPLAY, etc.)
     bb.utils.clean_environment()
 
+    cooker = bb.cooker.BBCooker(configuration, server)
+
     cooker.parseCommandLine()
 
     serverinfo = server.BitbakeServerInfo(cooker.server)