]> code.ossystems Code Review - openembedded-core.git/commitdiff
layer.conf: avoid unnecessary early expansion with :=
authorChristopher Larson <chris_larson@mentor.com>
Tue, 19 Mar 2013 01:55:07 +0000 (18:55 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 19 Mar 2013 11:52:21 +0000 (11:52 +0000)
bitbake handles immediate expansions of LAYERDIR for us automatically.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta-hob/conf/layer.conf
meta-skeleton/conf/layer.conf
meta/conf/layer.conf

index ea977e2cc3a3afa5e4a92648d6eca49191d1dc68..6df27ac5a354701e6287aad8858beddd480addd1 100644 (file)
@@ -1,11 +1,11 @@
 # We have a conf and classes directory, add to BBPATH
-BBPATH := "${BBPATH}:${LAYERDIR}"
+BBPATH .= ":${LAYERDIR}"
 
 # We have a packages directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb"
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
 
 BBFILE_COLLECTIONS += "hob"
-BBFILE_PATTERN_hob := "^${LAYERDIR}/"
+BBFILE_PATTERN_hob = "^${LAYERDIR}/"
 BBFILE_PRIORITY_hob = "1"
 
 # This should only be incremented on significant changes that will
index 4cf476711d2d9fd767e80737310e9950326516b7..10031c1e2ad4743cdd6f26b94f72575d5f2bef1e 100644 (file)
@@ -1,11 +1,11 @@
 # We have a conf and classes directory, add to BBPATH
-BBPATH := "${BBPATH}:${LAYERDIR}"
+BBPATH .= ":${LAYERDIR}"
 
 # We have a packages directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb"
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
 
 BBFILE_COLLECTIONS += "skeleton"
-BBFILE_PATTERN_skeleton := "^${LAYERDIR}/"
+BBFILE_PATTERN_skeleton = "^${LAYERDIR}/"
 BBFILE_PRIORITY_skeleton = "1"
 
 # This should only be incremented on significant changes that will
index 6e5cd0cf8d17a91c594e49f3a3f6a480db39648a..81f1071a9151f6f604cb0c243695da0ebfc0dfb1 100644 (file)
@@ -4,7 +4,7 @@ BBPATH .= ":${LAYERDIR}"
 BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
 
 BBFILE_COLLECTIONS += "core"
-BBFILE_PATTERN_core := "^${LAYERDIR}/"
+BBFILE_PATTERN_core = "^${LAYERDIR}/"
 BBFILE_PRIORITY_core = "5"
 
 # This should only be incremented on significant changes that will
@@ -12,10 +12,10 @@ BBFILE_PRIORITY_core = "5"
 LAYERVERSION_core = "1"
 
 # Set a variable to get to the top of the metadata location
-COREBASE := '${@os.path.normpath("${LAYERDIR}/../")}'
+COREBASE = '${@os.path.normpath("${LAYERDIR}/../")}'
 
 # Set path to qemu image tests included in this layer
-QEMUIMAGETESTS := "${COREBASE}/scripts/qemuimage-tests"
+QEMUIMAGETESTS = "${COREBASE}/scripts/qemuimage-tests"
 
 SIGGEN_EXCLUDERECIPES_ABISAFE += " \
   sysvinit-inittab \