]> code.ossystems Code Review - openembedded-core.git/commitdiff
libvorbis: use autotools_stage_all (fixing .la installation)
authorRoss Burton <ross@openedhand.com>
Thu, 10 Jan 2008 11:22:45 +0000 (11:22 +0000)
committerRoss Burton <ross@openedhand.com>
Thu, 10 Jan 2008 11:22:45 +0000 (11:22 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3449 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/libvorbis/libvorbis_1.0.1.bb

index 8a2d17a0ad090b5769099272a2f67fac335f4b61..70f279403fe99b65a637935ae52ce077a4ddcd4d 100644 (file)
@@ -4,12 +4,12 @@ DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
 that is free of intellectual property restrictions. libvorbis \
 is the main vorbis codec library."
 LICENSE = "BSD"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libvorbis-${PV}.tar.gz \
-file://m4.patch;patch=1"
+        file://m4.patch;patch=1"
 
-inherit autotools  pkgconfig
+inherit autotools pkgconfig
 
 # vorbisfile.c reveals a problem in the gcc register spilling for the
 # thumb instruction set...
@@ -19,14 +19,5 @@ EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
                --with-ogg-includes=${STAGING_INCDIR}"
 
 do_stage () {
-       oe_libinstall -a -so -C lib libvorbis ${STAGING_LIBDIR}
-       oe_libinstall -a -so -C lib libvorbisfile ${STAGING_LIBDIR}
-       oe_libinstall -a -so -C lib libvorbisenc ${STAGING_LIBDIR}
-
-       install -d ${STAGING_INCDIR}/vorbis
-       install -m 0644 include/vorbis/vorbisenc.h \
-                       include/vorbis/vorbisfile.h \
-                       include/vorbis/codec.h ${STAGING_INCDIR}/vorbis/
-       install -d ${STAGING_DATADIR}/aclocal
-       install -m 0644 vorbis.m4 ${STAGING_DATADIR}/aclocal/
+        autotools_stage_all
 }