]> code.ossystems Code Review - openembedded-core.git/commitdiff
classes/core-image: remove *_IMAGE_FEATURES variables
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Fri, 31 Aug 2012 09:37:59 +0000 (10:37 +0100)
committerSaul Wold <sgw@linux.intel.com>
Tue, 4 Sep 2012 05:52:50 +0000 (22:52 -0700)
This indirection does not add anything in terms of configuration and
only serves to increase confusion; and given the nature of these it is
unlikely they are being used outside of OE-Core. Change the sato-sdk and
sato-dev images to be based on the main Sato image (avoiding the need
for a common SATO_IMAGE_FEATURES variable) and eliminate all references
to them.

Fixes [YOCTO #2458].

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/classes/core-image.bbclass
meta/recipes-core/images/core-image-core.bb
meta/recipes-graphics/images/core-image-clutter.bb
meta/recipes-sato/images/core-image-sato-dev.bb
meta/recipes-sato/images/core-image-sato-sdk.bb
meta/recipes-sato/images/core-image-sato.bb

index f4013134d5e5eed53864137db13ed54eb7c05953..d6dd6460eb0ad93c126bb25c01eb69025cc233dd 100644 (file)
@@ -62,10 +62,6 @@ CORE_IMAGE_EXTRA_INSTALL ?= ""
 
 IMAGE_INSTALL ?= "${CORE_IMAGE_BASE_INSTALL}"
 
-X11_IMAGE_FEATURES  = "x11-base apps-x11-core package-management"
-ENHANCED_IMAGE_FEATURES = "${X11_IMAGE_FEATURES} apps-x11-games package-management"
-SATO_IMAGE_FEATURES = "${ENHANCED_IMAGE_FEATURES} x11-sato ssh-server-dropbear"
-
 inherit image
 
 # Create /etc/timestamp during image construction to give a reasonably sane default time setting
index ed33e12d46922d4e9e20d11b0c6c8e1efe0fef9f..ea6ba7ecad12908e0cc060237895659c1ed50a37 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "An X11 image with simple applications such as terminal, editor, \
 and file manager."
 
-IMAGE_FEATURES += "apps-console-core ${X11_IMAGE_FEATURES}"
+IMAGE_FEATURES += "apps-console-core package-management x11-base apps-x11-core"
 
 LICENSE = "MIT"
 
index 6c49a02625ae71c6f60510b9bef1504dd9481480..aa6e2a2bdda00df4ae1f9b67575045772175be8a 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "An image with support for the Open GL-based toolkit Clutter, \
 which enables development of rich and animated graphical user interfaces."
 
-IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES}"
+IMAGE_FEATURES += "apps-console-core package-management x11-base apps-x11-core apps-x11-games x11-sato ssh-server-dropbear"
 
 LICENSE = "MIT"
 
index 5ee9a04f362b699e8fdd07257c2f385d6adff10d..7fa69d0997a679c0b613053511df6380b8cb6dcf 100644 (file)
@@ -1,9 +1,7 @@
+require core-image-sato.bb
+
 DESCRIPTION = "Image with Sato for development work. It includes everything \
 within core-image-sato plus a native toolchain, application development and \
 testing libraries, profiling and debug symbols."
 
-IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES} dev-pkgs"
-
-LICENSE = "MIT"
-
-inherit core-image
+IMAGE_FEATURES += "dev-pkgs"
index 18ed0cd19257d156a7d09b8efac04141f238e057..1caca402f613f08aa1b94ca15c883864272e853a 100644 (file)
@@ -1,13 +1,11 @@
+require core-image-sato.bb
+
 DESCRIPTION = "Image with Sato support that includes everything within \
 core-image-sato plus meta-toolchain, development headers and libraries to \
 form a standalone SDK."
 
-IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES} dev-pkgs tools-sdk qt4-pkgs \
+IMAGE_FEATURES += "dev-pkgs tools-sdk qt4-pkgs \
        tools-debug tools-profile tools-testapps debug-tweaks ssh-server-openssh"
 
-LICENSE = "MIT"
-
-inherit core-image
-
 IMAGE_INSTALL += "kernel-dev"
 
index c228a35eb0d31b72b6c9b87476636e2c93e44214..4bbf099c436b93c227bb7b23d70b929e487338e5 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Image with Sato, a mobile environment and visual style for \
 mobile devices. The image supports X11 with a Sato theme, Pimlico \
 applications, and contains terminal, editor, and file manager."
 
-IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES}"
+IMAGE_FEATURES += "apps-console-core package-management x11-base apps-x11-core apps-x11-games x11-sato ssh-server-dropbear"
 
 LICENSE = "MIT"