]> code.ossystems Code Review - openembedded-core.git/commitdiff
xinput-calibrator: fix XDG launch
authorKoen Kooi <koen@dominion.thruhere.net>
Wed, 30 Apr 2014 09:33:23 +0000 (11:33 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 May 2014 16:59:05 +0000 (17:59 +0100)
In the move from meta-oe to OE-core XDG based launched was dropped
without noting it in the commit message, so fix that regression.

Gnome-session will now launch the calibrator again.

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb

index 3f97e197add36e9dc60bad4915d810e50b46bd78..95abfce816453cbb2b355ea3239015af4654e4a1 100644 (file)
@@ -25,7 +25,11 @@ do_install_append() {
 
     install -d ${D}${sysconfdir}/X11/Xsession.d/
     install -m 0755 ${WORKDIR}/30xinput_calibrate.sh ${D}${sysconfdir}/X11/Xsession.d/
+
+    install -d ${D}${sysconfdir}/xdg/autostart
+    sed -e 's,^Exec=.*,Exec=${bindir}/xinput_calibrator_once.sh,' ${S}/scripts/xinput_calibrator.desktop > ${D}${sysconfdir}/xdg/autostart/xinput_calibrator.desktop
 }
 
+FILES_${PN} += "${sysconfdir}/xdg/autostart"
 RDEPENDS_${PN} = "xinput formfactor"
 RRECOMMENDS_${PN} = "pointercal-xinput"