]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc: remove precompiled c++ headers as they take lot of space and are not required
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 6 Mar 2008 14:59:25 +0000 (14:59 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 6 Mar 2008 14:59:25 +0000 (14:59 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3969 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gcc/gcc-package.inc
meta/packages/gcc/gcc_4.2.2.bb

index 011c4fab63c60ac1da45d8a8c789ca35b3e0dbd7..0140126ba6fdbe3c60a67fec963e06525b1803fe 100644 (file)
@@ -126,6 +126,9 @@ do_install () {
        ln -sf gcc cc
        ln -sf ${bindir}/${TARGET_SYS}-cpp ${D}${base_libdir}/cpp
        ln -sf ${bindir}/${TARGET_SYS}-cpp ${D}${bindir}/cpp
+
+       # Remove precompiled c++ headers as they are really big
+       rm -rf ${D}${includedir}/c++/${BINV}/${TARGET_SYS}/bits/*.gch
 }
 
 # The gcc package contains symlinks that trip up insane
index 0a0e9cdd166e20375d792c66c154ef8961c09c95..d322de12962760ddda9eb3c82ccdf459657b81a1 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "The GNU cc and gcc C compilers."
 HOMEPAGE = "http://www.gnu.org/software/gcc/"
 SECTION = "devel"
 LICENSE = "GPL"
-PR = "r6"
+PR = "r7"
 
 inherit autotools gettext