]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl: fix CVE-2014-0221
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Mon, 9 Jun 2014 15:53:45 +0000 (16:53 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 10 Jun 2014 16:05:53 +0000 (17:05 +0100)
http://www.openssl.org/news/secadv_20140605.txt

DTLS recursion flaw (CVE-2014-0221)

By sending an invalid DTLS handshake to an OpenSSL DTLS client the code
can be made to recurse eventually crashing in a DoS attack.

Only applications using OpenSSL as a DTLS client are affected.

(Patch borrowed from Fedora.)

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/openssl/openssl-1.0.1e/openssl-1.0.1e-cve-2014-0221.patch [new file with mode: 0644]
meta/recipes-connectivity/openssl/openssl_1.0.1e.bb

diff --git a/meta/recipes-connectivity/openssl/openssl-1.0.1e/openssl-1.0.1e-cve-2014-0221.patch b/meta/recipes-connectivity/openssl/openssl-1.0.1e/openssl-1.0.1e-cve-2014-0221.patch
new file mode 100644 (file)
index 0000000..bf730a8
--- /dev/null
@@ -0,0 +1,38 @@
+commit d30e582446b027868cdabd0994681643682045a4
+Author: Dr. Stephen Henson <steve@openssl.org>
+Date:   Fri May 16 13:00:45 2014 +0100
+
+    Fix CVE-2014-0221
+    
+    Unnecessary recursion when receiving a DTLS hello request can be used to
+    crash a DTLS client. Fixed by handling DTLS hello request without recursion.
+    
+    Thanks to Imre Rad (Search-Lab Ltd.) for discovering this issue.
+
+Patch borrowed from Fedora
+Upstream-Status: Backport
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+diff --git a/ssl/d1_both.c b/ssl/d1_both.c
+index 07f67f8..4c2fd03 100644
+--- a/ssl/d1_both.c
++++ b/ssl/d1_both.c
+@@ -793,6 +793,7 @@ dtls1_get_message_fragment(SSL *s, int st1, int stn, long max, int *ok)
+       int i,al;
+       struct hm_header_st msg_hdr;
++      redo:
+       /* see if we have the required fragment already */
+       if ((frag_len = dtls1_retrieve_buffered_fragment(s,max,ok)) || *ok)
+               {
+@@ -851,8 +852,7 @@ dtls1_get_message_fragment(SSL *s, int st1, int stn, long max, int *ok)
+                                       s->msg_callback_arg);
+                       
+                       s->init_num = 0;
+-                      return dtls1_get_message_fragment(s, st1, stn,
+-                              max, ok);
++                      goto redo;
+                       }
+               else /* Incorrectly formated Hello request */
+                       {
+
index 38cdb3f740d1341551bb0e5e4a1e8286e8644eca..dc77330df8a582704c38e2dea9b07920ef431b05 100644 (file)
@@ -40,6 +40,7 @@ SRC_URI += "file://configure-targets.patch \
             file://CVE-2014-0160.patch \
             file://openssl-1.0.1e-cve-2014-0195.patch \
             file://openssl-1.0.1e-cve-2014-0198.patch \
+            file://openssl-1.0.1e-cve-2014-0221.patch \
            "
 
 SRC_URI[md5sum] = "66bf6f10f060d561929de96f9dfe5b8c"