]> code.ossystems Code Review - openembedded-core.git/commitdiff
freetype: enable 64 bit file support
authorSaul Wold <sgw@linux.intel.com>
Fri, 6 Jun 2014 00:09:04 +0000 (17:09 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Jun 2014 08:32:04 +0000 (09:32 +0100)
When running 32bit code on a large filessytem with 64bit inodes, the
fontcache was not being created correctly because an EOVERFLOW was being
returned from the fstat when reading the 64 inode on a 32bit system.

The fontcache is created at rootfs time on the host system via qemu.

[YOCTO #6338]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/freetype/freetype_2.5.3.bb

index 5d239e85fa98338312afaa48256188c32ae41187..122b8c04da9884428d7b79edd536bd43dfa161b9 100644 (file)
@@ -23,6 +23,8 @@ LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
 EXTRA_OEMAKE_class-native = ""
 EXTRA_OECONF = "--without-zlib --without-bzip2 CC_BUILD='${BUILD_CC}'"
+TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
+
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"