]> code.ossystems Code Review - openembedded-core.git/commitdiff
tiff: Security fix for CVE-2017-7595
authorRajkumar Veer <rveer@mvista.com>
Sat, 4 Nov 2017 05:27:08 +0000 (22:27 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 21 Nov 2017 14:42:55 +0000 (14:42 +0000)
Signed-off-by: Rajkumar Veer <rveer@mvista.com>
Signed-off-by: Armin Kuster <akuster@mvista.com>
meta/recipes-multimedia/libtiff/files/CVE-2017-7595.patch [new file with mode: 0644]
meta/recipes-multimedia/libtiff/tiff_4.0.7.bb

diff --git a/meta/recipes-multimedia/libtiff/files/CVE-2017-7595.patch b/meta/recipes-multimedia/libtiff/files/CVE-2017-7595.patch
new file mode 100644 (file)
index 0000000..851a37f
--- /dev/null
@@ -0,0 +1,48 @@
+commit 618d490090bfd10e613ac574ecff31a293904b44
+Author: erouault <erouault>
+Date:   Wed Jan 11 12:15:01 2017 +0000
+
+    * libtiff/tif_jpeg.c: avoid integer division by zero
+      in JPEGSetupEncode() when horizontal or vertical sampling is set to 0.
+      Fixes http://bugzilla.maptools.org/show_bug.cgi?id=2653
+
+Upstream-Status: Backport
+
+CVE: CVE-2017-7595
+Signed-off-by: Rajkumar Veer <rveer@mvista.com>
+
+Index: tiff-4.0.7/ChangeLog
+===================================================================
+--- tiff-4.0.7.orig/ChangeLog  2017-04-24 17:31:40.013832807 +0530
++++ tiff-4.0.7/ChangeLog       2017-04-24 18:03:34.769782616 +0530
+@@ -8,6 +8,12 @@
+ 2017-01-11 Even Rouault <even.rouault at spatialys.com>
++      * libtiff/tif_jpeg.c: avoid integer division by zero in
++      JPEGSetupEncode() when horizontal or vertical sampling is set to 0.
++      Fixes http://bugzilla.maptools.org/show_bug.cgi?id=2653
++
++2017-01-11 Even Rouault <even.rouault at spatialys.com>
++
+       * libtiff/tif_getimage.c: add explicit uint32 cast in putagreytile to
+       avoid UndefinedBehaviorSanitizer warning.
+       Patch by Nicolas Pena.
+Index: tiff-4.0.7/libtiff/tif_jpeg.c
+===================================================================
+--- tiff-4.0.7.orig/libtiff/tif_jpeg.c 2016-01-24 21:09:51.781641625 +0530
++++ tiff-4.0.7/libtiff/tif_jpeg.c      2017-04-24 18:05:59.777778815 +0530
+@@ -1626,6 +1626,13 @@
+       case PHOTOMETRIC_YCBCR:
+               sp->h_sampling = td->td_ycbcrsubsampling[0];
+               sp->v_sampling = td->td_ycbcrsubsampling[1];
++                if( sp->h_sampling == 0 || sp->v_sampling == 0 )
++                {
++                      TIFFErrorExt(tif->tif_clientdata, module,
++                                   "Invalig horizontal/vertical sampling value");
++                      return (0);
++                }
++
+               /*
+                * A ReferenceBlackWhite field *must* be present since the
+                * default value is inappropriate for YCbCr.  Fill in the
index 12ab9360a7f322ee81708c99cc45df87ad2022fc..6881c2456f9a4fc330dc32a0a9cdbfe38d160d2b 100644 (file)
@@ -21,6 +21,7 @@ SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
            file://CVE-2017-7592.patch \
            file://CVE-2017-7594-p1.patch \
            file://CVE-2017-7594-p2.patch \
+           file://CVE-2017-7595.patch \
         "
 
 SRC_URI[md5sum] = "77ae928d2c6b7fb46a21c3a29325157b"