]> code.ossystems Code Review - openembedded-core.git/commitdiff
curl: enable ssl support
authorSaul Wold <sgw@linux.intel.com>
Thu, 7 Jun 2012 12:00:00 +0000 (05:00 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 15 Jun 2012 14:09:17 +0000 (15:09 +0100)
This patch enables ssl support for curl to allow git to clone from
https / ssl sites. We do not want to enable gnutls for native or
nativesdk, as it adds additional dependency and increase build time

[YOCTO #2532]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/curl/curl_7.24.0.bb

index 12e95c9bc0861a3ecd9399177b39ded0795b87fa..f9dce7de1296b6b21efcca2d590849dea0c8d35b 100644 (file)
@@ -5,10 +5,10 @@ SECTION = "console/network"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
 
-DEPENDS = "zlib gnutls"
-DEPENDS_virtclass-native = "zlib-native"
-DEPENDS_virtclass-nativesdk = "zlib-nativesdk"
-PR = "r0"
+DEPENDS = "zlib gnutls openssl"
+DEPENDS_virtclass-native = "zlib-native openssl-native"
+DEPENDS_virtclass-nativesdk = "zlib-nativesdk openssl-nativesdk"
+PR = "r1"
 
 SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
            file://noldlibpath.patch \
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "ebdb111088ff8b0e05b1d1b075e9f1608285e8105cc51e21caacf33d01
 inherit autotools pkgconfig binconfig
 
 EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
-                --without-ssl \
+               --with-ssl \
                 --without-libssh2 \
                --with-random=/dev/urandom \
                --without-libidn \