]> code.ossystems Code Review - openembedded-core.git/commitdiff
binutils: Install non-alternatives links for nativesdk
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 17 Jan 2020 17:20:48 +0000 (17:20 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 8 Sep 2020 13:39:03 +0000 (14:39 +0100)
In the SDK we need the plain symlinks and don't use alternative providers.
When these are missing the toolchain can work incorrectly so fix this.

(From OE-Core rev: 0c06cfaa016d06cc56d80dc1c244a938f3d38a3c)

(From OE-Core rev: 0d299c5dc04407d2d54574157f4014f50f2d0468)

(From OE-Core rev: aa37b5fe0620122e47f36165f5c7a07d3328dba3)

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/binutils/binutils_2.31.bb

index 3dcc837c7871eb43447d5f27906a9a9e02e252fb..625e18c787f5b3bed31f6cbc53f2b4e233cd78ad 100644 (file)
@@ -48,4 +48,7 @@ FILES_libbfd = "${libdir}/libbfd-*.so"
 
 SRC_URI_append_class-nativesdk =  "file://nativesdk-relocation.patch"
 
+USE_ALTERNATIVES_FOR_class-nativesdk = ""
+FILES_${PN}_append_class-nativesdk = " ${bindir}"
+
 BBCLASSEXTEND = "native nativesdk"