]> code.ossystems Code Review - openembedded-core.git/commitdiff
openjade-native: Set datadir explicitly
authorScott Garman <scott.a.garman@intel.com>
Thu, 17 Feb 2011 21:30:14 +0000 (13:30 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 18 Feb 2011 01:16:26 +0000 (01:16 +0000)
datadir was previously defaulting to usr/share and hence could not
find openjade's data files.

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-devtools/openjade/openjade-native_1.3.2.bb

index f267fc54831ebf799e3edce4383a6c53c1ebca64..3615ec3721275ad00133e4170ca39a1bf9dd07d1 100644 (file)
@@ -7,7 +7,7 @@ SECTION = "base"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
 
-PR = "r0"
+PR = "r1"
 
 DEPENDS = "opensp-native sgml-common-native"
 RDEPENDS_${PN} = "sgml-common"
@@ -23,6 +23,10 @@ inherit autotools native
 EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
                 --enable-splibdir=${STAGING_LIBDIR}"
 
+# We need to set datadir explicitly, but adding it to EXTRA_OECONF
+# results in it being specified twice when configure is run.
+CONFIGUREOPTS := "${@d.getVar('CONFIGUREOPTS', True).replace('--datadir=${datadir}', '--datadir=${STAGING_DATADIR}/sgml/openjade-${PV}')}"
+
 CFLAGS =+ "-I${S}/include"
 
 do_install() {