]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add XServer fallback settings for unknown machine
authorMatthew Allum <mallum@openedhand.com>
Tue, 3 Oct 2006 10:39:24 +0000 (10:39 +0000)
committerMatthew Allum <mallum@openedhand.com>
Tue, 3 Oct 2006 10:39:24 +0000 (10:39 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@786 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/xserver-kdrive-common/xserver-kdrive-common/etc/X11/Xserver
meta/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb

index ad053533510984ca092582763fea8f2a974a72fb..8828f60434783cbc3b0a86546e8229418b3718ef 100644 (file)
@@ -18,6 +18,14 @@ fi
 
 . /etc/profile
 
+fallback_screen_arg() {
+    geom=`fbset | grep geometry`
+    w=`echo $geom | awk '{ print $2 }'`
+    h=`echo $geom | awk '{ print $3 }'`
+    b=`echo $geom | awk '{ print $6 }'`
+    echo -n "${w}x${h}x${b}"
+} 
+
 module_id() {
     ## used to read from assets, but sometimes assets is corrupted
     # grep "Module ID" /proc/hal/assets | sed "s/.*://"
@@ -75,6 +83,13 @@ case `module_id` in
                 modprobe mbxfb
                ARGS="$ARGS -fb /dev/fb1"
                 ;;
+        *)
+               # Its a device we dont know about - in which case force
+                # kdrive to use the current framebuffer geometry otherwise
+               # it will defualt to trying to achieve 1024x768 
+               S=`fallback_screen_arg`
+               ARGS="$ARGS -screen $S"
+               ;;
 esac
 
 DISPLAY=':0'
index bccd58a220bd768cc2df43535ca23b2ac8d1c0ee..c076a3435a31d5b9d50af28ac78313497605a61d 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Common X11 scripts"
 LICENSE = "GPL"
 SECTION = "x11"
 RDEPENDS_${PN} = "xmodmap libxrandr xdpyinfo xtscal xinit"
-PR = "r8"
+PR = "r9"
 
 SRC_URI = "file://etc"
 S = ${WORKDIR}