]> code.ossystems Code Review - openembedded-core.git/commitdiff
documentation/poky-ref-manual: Update packages references to recipes and make sure...
authorRichard Purdie <rpurdie@linux.intel.com>
Tue, 19 Oct 2010 19:18:32 +0000 (20:18 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 19 Oct 2010 19:18:32 +0000 (20:18 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
documentation/poky-ref-manual/bsp.xml
documentation/poky-ref-manual/extendpoky.xml

index e0ca31732b0deaccba245e291d8db4e94b8e51bb..9982f9e739ea88a1a2b699775d60e756cf62fa99 100644 (file)
@@ -105,8 +105,8 @@ meta-bsp/prebuilds/
 # We have a conf directory, add to BBPATH
 BBPATH := "${BBPATH}${LAYERDIR}"
 
-# We have a packages directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/packages/*/*.bb"
+# We have a recipes directory containing .bb and .bbappend files, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/recipes/*/*.bb ${LAYERDIR}/recipes/*/*.bbappend"
 
 BBFILE_COLLECTIONS += "bsp"
 BBFILE_PATTERN_bsp := "^${LAYERDIR}/"
@@ -115,7 +115,7 @@ BBFILE_PRIORITY_bsp = "5"
             </para>
 
             <para>
-                which simply makes bitbake aware of the packages and conf directories.
+                which simply makes bitbake aware of the recipes and conf directories.
             </para>
 
             <para>
index 57e085f403a0fae0c148422e50e1520cb9391548..aedd7c1c68decc87c1b8b8f04320aaf726b96378 100644 (file)
@@ -606,7 +606,7 @@ BBLAYERS = " \
 
           <para>
                Bitbake parses the conf/layer.conf of each of the layers in BBLAYERS
-               to add the layers packages, classes and configuration to Poky.
+               to add the recipes, classes and configuration contained within the layer to Poky.
                To create your own layer, independent of the main Poky repository,
                you need only create a directory with a conf/layer.conf file and
                add the directory to your bblayers.conf.
@@ -617,9 +617,9 @@ BBLAYERS = " \
                <literallayout class='monospaced'># We have a conf and classes directory, add to BBPATH
 BBPATH := "${BBPATH}:${LAYERDIR}"
 
-# We have a packages directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/packages/*/*.bb \
-        ${LAYERDIR}/packages/*/*.bbappend"
+# We have a recipes directory containing both .bb and .bbappend files, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/recipes/*/*.bb \
+        ${LAYERDIR}/recipes/*/*.bbappend"
 
 BBFILE_COLLECTIONS += "emenlow"
 BBFILE_PATTERN_emenlow := "^${LAYERDIR}/"