]> code.ossystems Code Review - openembedded-core.git/commitdiff
glib-networking: Ensure certificates are consistently disabled
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Sep 2011 16:15:59 +0000 (17:15 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Sep 2011 21:28:34 +0000 (22:28 +0100)
Currently configure is looking whether the build system has certificates
to determine the certificate paths. This is clear contamination so
this patch disables that functionality to ensure builds are consistent.

We could equally set this option to a consistent path if we start
installing certificates.

[YOCTO #1451]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glib-networking/glib-networking_2.28.7.bb

index f492dd3629a9077f28d8fc797ee241399999d405..521c9252c29c12d24c4a039137c05cde542391fa 100644 (file)
@@ -15,6 +15,8 @@ SRC_URI = "${GNOME_MIRROR}/${BPN}/2.28/${BPN}-${PV}.tar.bz2"
 SRC_URI[md5sum] = "c10e51571d03c10111a37bcd21fbf777"
 SRC_URI[sha256sum] = "98bedfbd530c4b1b53c91025fe82290bafd289d249e4eb549c3b90d23a76021c"
 
+EXTRA_OECONF = "--without-ca-certificates"
+
 inherit autotools pkgconfig
 
 FILES_${PN} += "${libdir}/gio/modules/libgio* ${datadir}/dbus-1/services/"