]> code.ossystems Code Review - openembedded-core.git/commitdiff
neon: build the test suite to verify neon links
authorRoss Burton <ross.burton@intel.com>
Tue, 9 Jun 2015 18:57:52 +0000 (19:57 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 11 Jun 2015 22:55:45 +0000 (23:55 +0100)
Without building a binary it's impossible to tell if a library will link
correctly, so build the test suite in do_compile().

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/neon/neon_0.30.1.bb

index 9245244eb86b8740ae16510a482abc8062af3ec6..fd170bc0cb7ba47aed29c37483ed3afccb9fa484 100644 (file)
@@ -20,3 +20,7 @@ inherit autotools binconfig-disabled lib_package pkgconfig
 
 EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"
 EXTRA_OECONF += "--without-gssapi"
+
+do_compile_append() {
+       oe_runmake -C test
+}