]> code.ossystems Code Review - openembedded-core.git/commitdiff
owl-video: patches pushed upstream, so bump srcrev
authorRoss Burton <ross.burton@intel.com>
Fri, 10 Aug 2012 12:45:06 +0000 (15:45 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 17 Aug 2012 17:04:09 +0000 (18:04 +0100)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-sato/owl-video-widget/owl-video/gtk_multithread_safe.patch [deleted file]
meta/recipes-sato/owl-video-widget/owl-video/make-382.patch [deleted file]
meta/recipes-sato/owl-video-widget/owl-video_git.bb

diff --git a/meta/recipes-sato/owl-video-widget/owl-video/gtk_multithread_safe.patch b/meta/recipes-sato/owl-video-widget/owl-video/gtk_multithread_safe.patch
deleted file mode 100644 (file)
index 437f72b..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-Use gdk_threads_enter/gdk_threads_leave to ensure gtk multithread safe
-
-If the video player tries to play an unknown type file, it will enter
-the error_cb() function, which is called in another thread.
-Use gdk_threads_enter/gdk_threads_leave to ensure the safe of gtk
-multi-thread operation.
-
-Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
-
-Upstream-Status: Pending
-
-diff -ruN video-orig/src/video.c video/src/video.c
---- video-orig/src/video.c     2010-10-15 16:07:26.522346398 +0800
-+++ video/src/video.c  2010-10-15 16:25:51.780296717 +0800
-@@ -96,6 +96,7 @@
- {
-         GtkWidget *dialog;
-+        gdk_threads_enter();
-         dialog = gtk_message_dialog_new (data->window,
-                                          GTK_DIALOG_NO_SEPARATOR,
-                                          GTK_MESSAGE_ERROR,
-@@ -103,6 +104,7 @@
-                                          error->message);
-         gtk_dialog_run (GTK_DIALOG (dialog));
-         gtk_widget_destroy (dialog);
-+        gdk_threads_leave();
- }
- /**
-@@ -606,7 +608,9 @@
-         
-         gtk_widget_show_all (GTK_WIDGET (data->window));
-+        gdk_threads_enter();
-         gtk_main ();
-+        gdk_threads_leave();
-         /**
-          * Cleanup.
diff --git a/meta/recipes-sato/owl-video-widget/owl-video/make-382.patch b/meta/recipes-sato/owl-video-widget/owl-video/make-382.patch
deleted file mode 100644 (file)
index d219c31..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Make 3.82 is much stricter and demands tabs. Obey.
-
-JL - 15/12/10
-
-Upstream-Status: Inappropriate [configuration]
-
-Index: video/Makefile.am
-===================================================================
---- video.orig/Makefile.am
-+++ video/Makefile.am
-@@ -4,5 +4,5 @@ SUBDIRS = src
- MAINTAINERCLEANFILES = aclocal.m4 compile config.guess config.sub configure depcomp intltool-extract intltool-merge intltool-update install-sh ltmain.sh Makefile.in missing
- snapshot:
--        $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
-+      $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
index bc632736414c029dc6b03e6c214e873777826c8a..ae083839f3b590ded4713a8e8e7d35940c3b2d78 100644 (file)
@@ -8,22 +8,20 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ac14b7ca45afea5af040da54db270eb0 \
 SECTION = "x11"
 DEPENDS = "libowl-av"
 
-SRCREV = "f133472318970796fae1ea3e98ac062156768baf"
+SRCREV = "07ab48f331a5e6e0d169e4892c7eb1fc22dc0b9d"
 PV = "0.1+git${SRCPV}"
-PR = "r1"
+PR = "r2"
 
 S = "${WORKDIR}/git"
 
 SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
-           file://gtk_multithread_safe.patch \
            file://owl-video-widget.png \
            file://stock_media-play.png \
            file://stock_volume-0.png \
            file://stock_volume-min.png \
            file://stock_volume-med.png \
            file://stock_volume-max.png \
-           file://owl-video-widget.desktop \
-          file://make-382.patch"
+           file://owl-video-widget.desktop"
 
 inherit autotools pkgconfig