]> code.ossystems Code Review - openembedded-core.git/commitdiff
build-appliance-image: Load TUN at startup
authorJuro Bystricky <juro.bystricky@intel.com>
Fri, 15 Apr 2016 00:49:30 +0000 (17:49 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Apr 2016 15:27:45 +0000 (16:27 +0100)
This patch addresses the issue of not being able to execute "runqemu"
in the Build Appliance.
The root cause of the problem was that TAP/TUN was not available,
although required by "runqemu". In addition, the recommended remedy

  $ sudo modprobe tun

would fail for two reasons: modprobe not in PATH (user builder),
and "iptables" located in /usr/sbin but expected in /sbin.

[YOCTO #9437]

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/images/build-appliance-image_14.0.0.bb

index eeb301df570de8a54058f854e747097c8bbcbaf7..07bd14506e99c2a8ce846d41daa3e99423dd84ff 100644 (file)
@@ -21,7 +21,7 @@ IMAGE_FSTYPES = "vmdk"
 
 inherit core-image module-base
 
-SRCREV ?= "00c4c9bf0007b964dfa4559fe8fc8687f14cdec3"
+SRCREV ?= "5c8124df2efed4b8691239cd357cf69211b0c844"
 SRC_URI = "git://git.yoctoproject.org/poky \
            file://Yocto_Build_Appliance.vmx \
            file://Yocto_Build_Appliance.vmxf \
@@ -80,9 +80,13 @@ fakeroot do_populate_poky_src () {
        # Assume we will need CDROM to install guest additions
        mkdir -p ${IMAGE_ROOTFS}/media/cdrom
 
-       # Allow builder to use sudo to setup tap/tun
+       # Allow builder to use sudo
        echo "builder ALL=(ALL) NOPASSWD: ALL" >> ${IMAGE_ROOTFS}/etc/sudoers
 
+       # Load tap/tun at startup
+       ln -sr ${IMAGE_ROOTFS}/usr/sbin/iptables ${IMAGE_ROOTFS}/sbin/iptables
+       echo "tun" >> ${IMAGE_ROOTFS}/etc/modules
+
        # Use Clearlooks GTK+ theme
        mkdir -p ${IMAGE_ROOTFS}/etc/gtk-2.0
        echo 'gtk-theme-name = "Clearlooks"' > ${IMAGE_ROOTFS}/etc/gtk-2.0/gtkrc