]> code.ossystems Code Review - openembedded-core.git/commitdiff
bdwgc: enable full version name in recipe name
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>
Tue, 4 Jun 2013 06:52:20 +0000 (09:52 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 4 Jun 2013 14:53:47 +0000 (15:53 +0100)
bdwgc has version names that may or may not contain a revision
(for example 7.2d or simply 7.2). The current recipe specifies
the revision as a separate variable, which confuses the automatic
version checker. This patch enables using the full version name
as part of the recipe name.

Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/bdwgc/bdwgc_7.2d.bb [moved from meta/recipes-support/bdwgc/bdwgc_7.2.bb with 92% similarity]

similarity index 92%
rename from meta/recipes-support/bdwgc/bdwgc_7.2.bb
rename to meta/recipes-support/bdwgc/bdwgc_7.2d.bb
index a0a5bffba9f6200922da358157555a248dade737..46e5257671d867d2302cc1c8ae3d89676d640554 100644 (file)
@@ -23,17 +23,14 @@ LIC_FILES_CHKSUM = "file://README.QUICK;md5=9b9dd874f6940641b6ab19893ee8f1cc \
                     file://doc/README;md5=92e7dd0334d1f672b699cd0aca08bef0 \
                     file://libatomic_ops/doc/LICENSING.txt;md5=607073e04548eac7d1f763e480477bab"
 
-REVISION = "d"
-
-SRC_URI = "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-${PV}${REVISION}.tar.gz"
+SRC_URI = "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-${PV}.tar.gz"
 
 SRC_URI[md5sum] = "91340b28c61753a789eb6077675d87d2"
 SRC_URI[sha256sum] = "d9fe0ae8650d43746a48bfb394cab01a319f3809cee19f8ebd16aa985b511c5e"
 FILES_${PN}-doc = "/usr/share"
 
-PR = "r0"
-
-S = "${WORKDIR}/gc-${PV}"
+REAL_PV = "${@[d.getVar('PV',1)[:-1], d.getVar('PV',1)][(d.getVar('PV',1)[-1]).isdigit()]}"
+S = "${WORKDIR}/gc-${REAL_PV}"
 
 ARM_INSTRUCTION_SET = "arm"