]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/5.4: ARM: 8918/2: only build return_address() if needed
authorBruce Ashfield <bruce.ashfield@gmail.com>
Tue, 24 Mar 2020 23:05:02 +0000 (19:05 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Mar 2020 23:07:55 +0000 (23:07 +0000)
Integrating the following commit(s) to linux-yocto/5.4:

    03142acba06e ARM: 8918/2: only build return_address() if needed

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
meta/recipes-kernel/linux/linux-yocto_5.4.bb

index 2eb1e846e8d4c4f004a718dabd372b1ddd70aa08..7037d980d23076a46b4015f3203e9ce5037a15bc 100644 (file)
@@ -11,7 +11,7 @@ python () {
         raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
 }
 
-SRCREV_machine ?= "87d86ed4bfc78baee66933982c2962309fca4ffe"
+SRCREV_machine ?= "79037ae58e6b0dfd0c63d4a0e131f1bd5efe7e53"
 SRCREV_meta ?= "d40bf6ad14acc6d84d5c9a8e2c794ce37ffa16ff"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
index 18ff195af3297b69aa3fb6642c731076f98f1c05..2a621622eb90369e3269428e076bbdda011765df 100644 (file)
@@ -15,8 +15,8 @@ DEPENDS += "openssl-native util-linux-native"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine_qemuarm ?= "b6bb0cf2d13aca397c216c2323985c87ac98919a"
-SRCREV_machine ?= "9065d188f87410b7c862e44ff3143648c1ad2295"
+SRCREV_machine_qemuarm ?= "5c2d35eeb4be0e8bae4cf5ee0733e41ff1262ff3"
+SRCREV_machine ?= "03142acba06e8b33888410a518358a626dceb720"
 SRCREV_meta ?= "d40bf6ad14acc6d84d5c9a8e2c794ce37ffa16ff"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 8db3d1c9743ea731d795ab2ed12d2e403699de17..0f1cd07945e5857f179cdc098ae7bea7417800c4 100644 (file)
@@ -12,15 +12,15 @@ KBRANCH_qemux86  ?= "v5.4/standard/base"
 KBRANCH_qemux86-64 ?= "v5.4/standard/base"
 KBRANCH_qemumips64 ?= "v5.4/standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "9f04047a4f31450342960f04571194122e890461"
-SRCREV_machine_qemuarm64 ?= "9065d188f87410b7c862e44ff3143648c1ad2295"
-SRCREV_machine_qemumips ?= "f6f24e8e404d1debf07cb5793a183ba8e759d09b"
-SRCREV_machine_qemuppc ?= "9065d188f87410b7c862e44ff3143648c1ad2295"
-SRCREV_machine_qemuriscv64 ?= "9065d188f87410b7c862e44ff3143648c1ad2295"
-SRCREV_machine_qemux86 ?= "9065d188f87410b7c862e44ff3143648c1ad2295"
-SRCREV_machine_qemux86-64 ?= "9065d188f87410b7c862e44ff3143648c1ad2295"
-SRCREV_machine_qemumips64 ?= "6f93582af92ab433d43c2a67a7ed871e5c229e55"
-SRCREV_machine ?= "9065d188f87410b7c862e44ff3143648c1ad2295"
+SRCREV_machine_qemuarm ?= "ab849248b45403c7d6f1fb8e8f57840cc2880618"
+SRCREV_machine_qemuarm64 ?= "03142acba06e8b33888410a518358a626dceb720"
+SRCREV_machine_qemumips ?= "967a1708cbbfe1b524dc28f04fa5e0d79a270bf5"
+SRCREV_machine_qemuppc ?= "03142acba06e8b33888410a518358a626dceb720"
+SRCREV_machine_qemuriscv64 ?= "03142acba06e8b33888410a518358a626dceb720"
+SRCREV_machine_qemux86 ?= "03142acba06e8b33888410a518358a626dceb720"
+SRCREV_machine_qemux86-64 ?= "03142acba06e8b33888410a518358a626dceb720"
+SRCREV_machine_qemumips64 ?= "d3e850da830241c424d557a6a072527e09e784ab"
+SRCREV_machine ?= "03142acba06e8b33888410a518358a626dceb720"
 SRCREV_meta ?= "d40bf6ad14acc6d84d5c9a8e2c794ce37ffa16ff"
 
 # remap qemuarm to qemuarma15 for the 5.4 kernel